Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157922 - Seg fault during animation rendering
Summary: Seg fault during animation rendering
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-05-17 05:43 UTC by Brian G. Anderson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-02 16:21:34 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2005-05-17 05:43:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
I'm running FC4T3 using blender from fedora extras.  I was running through the blender documentation doing the "Your first animation in 30+30 minutes".  At the end of the "posing" section (the seond to last) one is instructed to view the animation by doing Alt-A.  Doing this causes blender to seg fault.

I ran it under gdb and got this info

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208596800 (LWP 5286)]
0x0393ca25 in __gnu_cxx::__pool<true>::_M_reclaim_block ()
   from /usr/lib/libstdc++.so.6
(gdb)


Version-Release number of selected component (if applicable):
blender-2.35-1

How reproducible:
Always

Steps to Reproduce:
1.do blender animation tutorial 
2.set up armiture and skin and poses for 40 frames
3.run Alt-A to view animation.
  

Actual Results:  seg fault

Expected Results:  animation preview

Additional info:

Comment 1 Toshio Kuratomi 2005-06-07 01:04:40 UTC
There will soon be a blender-2.37-2 in the FE4 repository.  If you're impatient
it is presently here:
  http://extras64.linux.duke.edu/needsign/4/blender/2.37-2/

Would you please retest with this version and report whether the crash still occurs?

Comment 2 Michael Schwendt 2005-07-10 21:17:20 UTC
On Fedora Core Development, "yum install blender" installed an old
blender-2.35-1, which causes trouble here while trying briefly to get a more
detailed traceback. Before I'm going to switch to FE4, I see this during start:

$ blender 
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
No installed Python found.
Only built-in modules are available.  Some scripts may not run.
Continuing happily.


And this in gdb:

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread -1208964672 (LWP 14801)]
0x00a96dfc in _mesa_test_os_sse_exception_support ()
   from /usr/X11R6/lib/modules/dri/mga_dri.so


Inside Blender, the entire GUI flickers heavily. Widget colouring is corrupted.
Menus appear transparent. Close to unusable. Needs a rebuild. It was last built
Dec 2004.



Comment 3 Michael Schwendt 2005-07-11 07:21:35 UTC
With blender-2.37-2, I see the same heavy GUI flickering. Hence I can't be of
any help trying to get a more detailed backtrace. One observation, though.
Loading example files and Alt+A gives animations and doesn't crash. Makes me
assume it's not a general problem, but think that the 2.35-1 binary from Dec
2004 was also too old for FC4T3.


Comment 4 Jochen Schmitt 2006-02-12 18:25:26 UTC
Can you update to blender 2.41 and try again.

Best Regards:

Jochen Schmitt

Comment 5 Hans de Goede 2006-11-13 12:44:55 UTC
I'm doing some FE bug triaging, perhaps this bug should be closed due to lack of
the original reporter, esp. since you cannot reproduce it?


Comment 6 Jochen Schmitt 2007-07-02 16:21:34 UTC
OK, I hope, the reported bug may fixed in the current version of blender. So I
will close this bug.

I the issue persist, the bug may be reopen.


Note You need to log in before you can comment on or make changes to this bug.