Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157914 - printing uses bold font in place of regular for indic languages
Summary: printing uses bold font in place of regular for indic languages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeprint22
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On: 138073
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-17 01:42 UTC by Leon Ho
Modified: 2013-03-13 04:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-13 07:42:25 UTC


Attachments (Terms of Use)
fixed font (deleted)
2005-06-16 14:28 UTC, Caolan McNamara
no flags Details

Description Leon Ho 2005-05-17 01:42:52 UTC
+++ This bug was initially created as a clone of Bug #138073 +++

Description of problem:
When printing a mail with indic text from evolution, the indic text is
printed with the bold font, regardless of the onscreen formatting. 

Version-Release number of selected component (if applicable):
libgnomeprint22-2.8.0-2

How reproducible:
Every time

Steps to Reproduce:
1. Compose a mail in evolution with indic
2. print mail to ps file
3.
  
Actual results:
all indic text is printed in bold face

Expected results:
printing should use regular face

Additional info:
- This was tested with gujarati and hindi text. 
- The bold lohit font is not yet included in CVS - its available from:
  http://bob.brisbane.redhat.com/~jnansi/pkgs/
- I have also tested by formatting part of the text as bold, italics, 
  etc. In all cases, the printed output allways uses the bold face.

Comment 1 Caolan McNamara 2005-06-16 14:28:42 UTC
Created attachment 115540 [details]
fixed font

try with this replacement Bold font for Lohit Hindi, if it works which I
believe it will, see rh#138189#

Comment 2 Akira TAGOH 2006-09-13 07:42:25 UTC
on the latest fonts-indic packages, it looks like working now. but without
emboldening even if the bold style is chosen, due to Bug#171693. closing.


Note You need to log in before you can comment on or make changes to this bug.