Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157867 - unison crash when replicating files
Summary: unison crash when replicating files
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: unison
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL: http://groups.yahoo.com/group/unison-...
Whiteboard:
Depends On:
Blocks: FE4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-16 16:10 UTC by Cosme Corrêa
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 18:33:10 UTC


Attachments (Terms of Use)

Description Cosme Corrêa 2005-05-16 16:10:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
In unison's list: 
http://groups.yahoo.com/group/unison-users/message/3888 
 
 
 >> I'm using Unison 2.10.2 in Fedora Core 3. 
 >> What is wrong? 
 >> 
 >> TIA. 
 >> 
 >> This is the error: 
 >> [BGN] Updating file penna/.kde/share/config/kdeglobals 
 >> from /home 
 >> to //serv.xpto.com//home 
 >> Uncaught exception File 
 >> "/rpmbuild/extras/cvs/rpms/unison/FC-3/unison-2.10.2/transport.ml", 
 >> line 21, characters 6-12: Assertion failed 
>  
> This is a known bug in version 2.10.2; see 
> http://groups.yahoo.com/group/unison-users/message/3199 and the response 
> with a patch from Jerome Vouillon. So you have several options: 
>  
> (1) Ask the Unison maintainer for FC3 to apply the patch and release a 
> new version; 
>  
> (2) Grab the Unison source, apply the patch, and build it yourself; 
>  
> (3) Upgrade to the latest beta version, 2.12.0. 
>  
> Good luck, 
> Andrew. 

Version-Release number of selected component (if applicable):
unison-2.10.2-2

How reproducible:
Sometimes

Steps to Reproduce:
1.Just put unison to work 
2. 
3. 
   

Actual Results:  ? 

Expected Results:  Work? 

Additional info:

It is a "famous bug" in unison list. 
There is a pach too. 
 
http://groups.yahoo.com/group/unison-users/message/3199

Comment 1 Gérard Milmeister 2005-05-16 18:33:10 UTC
I applied the patch and submitted the package for rebuilding.

Comment 2 Cosme Corrêa 2005-05-16 19:44:17 UTC
(In reply to comment #1)
> I applied the patch and submitted the package for rebuilding.

Please, where can I get it?
I am having problens in my production environment. :-(

Comment 3 Michael Schwendt 2005-05-17 13:57:53 UTC
Since a build request has been submitted, once built the binaries would go into
a temporary repository until they are signed by a release master. After that,
they would show up in the Fedora Extras for FC3 repository. Meanwhile you could
check out the updated package from CVS: http://cvs.fedora.redhat.com



Note You need to log in before you can comment on or make changes to this bug.