Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157816 - font not selected when copy and paste multi-lingual text
Summary: font not selected when copy and paste multi-lingual text
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On: 157623
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-16 06:12 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
4 users (show)

Fixed In Version: 1.9.108-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-10 15:24:21 UTC


Attachments (Terms of Use)
screenshot comparing the original text from gedit and output from oowriter after c'n'p (deleted)
2005-05-16 06:12 UTC, Lawrence Lim
no flags Details
multi-lingual text (deleted)
2005-05-16 06:14 UTC, Lawrence Lim
no flags Details
screenshot with openoffice.org-1.9.108-1 (deleted)
2005-06-10 01:33 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2005-05-16 06:12:42 UTC
Description of problem:
If user copy and paste a multi-lingual document from gedit to oowriter using
third mouse button or ctrl-c & ctrl-v combo, oowriter will not be able to
display the information properly.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.100-1

How reproducible:
Always

Steps to Reproduce:
1.select all the text from the text file attached
2.copy and paste into oowriter using third mouse or ctrl-c/ctrl-v combo
3.
  
Actual results:
unable to display all the text, screenshot attached

Expected results:
able to display all the text

Additional info:

Comment 1 Lawrence Lim 2005-05-16 06:12:42 UTC
Created attachment 114411 [details]
screenshot comparing the original text from gedit and output from oowriter after c'n'p

Comment 2 Lawrence Lim 2005-05-16 06:14:48 UTC
Created attachment 114412 [details]
multi-lingual text

Comment 4 Lawrence Lim 2005-06-10 01:32:06 UTC
Checked with 1.9.108-1, confirmed fixed for CJKI. For Indic, bn, gu, and hi are
not rendered properly. Prolly due to bug 157813.


Thanks! 

Comment 5 Lawrence Lim 2005-06-10 01:33:18 UTC
Created attachment 115280 [details]
screenshot with openoffice.org-1.9.108-1

Comment 6 Caolan McNamara 2005-06-10 15:24:21 UTC
leaving rh#157813# aside this works in 1.9.108-4 for rawhide/fc4-update-candidate


Note You need to log in before you can comment on or make changes to this bug.