Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157813 - unable to render bn, gu and hi properly
Summary: unable to render bn, gu and hi properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Indic FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-16 03:58 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
3 users (show)

Fixed In Version: 1.9.112
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 08:53:42 UTC


Attachments (Terms of Use)
screenshot comparing gedit and oowriter rendering (deleted)
2005-05-16 03:58 UTC, Lawrence Lim
no flags Details
output from oowriter doc (deleted)
2005-05-16 04:01 UTC, Lawrence Lim
no flags Details
output from gedit (deleted)
2005-05-16 04:01 UTC, Lawrence Lim
no flags Details
screenshot of indic rendering in oowriter (deleted)
2005-06-22 01:12 UTC, Lawrence Lim
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 50571 None None None Never

Description Lawrence Lim 2005-05-16 03:58:01 UTC
Description of problem:
Tested with ooowriter, seems that indic characters for bn_IN, gu_IN and hi_IN
are not able to render properly.

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.100-1

How reproducible:
Always

Steps to Reproduce:
1.in GNOME desktop, start oowriter
2.using GIMLET to switch between different locale, enter 'kg' for each locale
3.
  
Actual results:
bn_IN, gu_IN and hi_IN not rendering properly.

Expected results:
As observed in gedit attached

Additional info:
Screenshot attached comparing gedit and oowriter rendering

Comment 1 Lawrence Lim 2005-05-16 03:58:01 UTC
Created attachment 114404 [details]
screenshot comparing gedit and oowriter rendering

Comment 2 Lawrence Lim 2005-05-16 04:01:07 UTC
Created attachment 114405 [details]
output from oowriter doc

Comment 3 Lawrence Lim 2005-05-16 04:01:39 UTC
Created attachment 114406 [details]
output from gedit

Comment 5 Leon Ho 2005-05-16 05:52:08 UTC
Lawrence, try to rm -rf ~/.openoffice* and see if it goes better for you 

Comment 6 Lawrence Lim 2005-05-16 06:00:16 UTC
RE Comment #5, unfortunately, no that did not help.

Comment 8 Dan Williams 2005-05-18 19:19:30 UTC
The patch that I submitted upstream from the RHEL4 work _is_ present in current
versions.  (ie, vcl/source/glyphs/gcach_layout.cxx -
IcuLayoutEngine::operator(), RHEL4 patch is
patches-vclplug-i18n-indic-bug-fixes.diff).

This is most likely related to Bug 157815 such that a fix for one is likely to
solve the other.

Comment 9 Dan Williams 2005-05-18 19:21:39 UTC
Just to complete the previous comment, what I mean is that additional work is
necessary, since it is not the case that our RHEL4 patch was missing or incomplete.

Comment 10 Leon Ho 2005-05-23 04:55:04 UTC
This is a pretty big regression. Is it possible to resolve it in time?

Comment 11 Dan Williams 2005-05-23 13:36:08 UTC
given the fact that I can't even get OOo to _build_ right now (been trying since
Friday morning) due to gij/gcj stuff with berkeleydb, I'm not sure...  I did fix
an issue with Gujarati showing up as all squares due to font/glyph substitution
on Friday, but of course I haven't been able to build that yet.


Comment 14 Lawrence Lim 2005-06-10 03:05:20 UTC
Tested with openoffice.org-1.9.108-1, bug still exist.

Comment 15 Caolan McNamara 2005-06-13 12:59:12 UTC
I've attached a patch to http://www.openoffice.org/issues/show_bug.cgi?id=50571
which fixes this for me. Will build and make test available.

Comment 16 Lawrence Lim 2005-06-21 05:25:49 UTC
Hi Caolan,
Will a test package be availalble for testing before FC4-updates commence??

Comment 17 Caolan McNamara 2005-06-21 07:53:30 UTC
>= 1.9.109-3 should have this fix. Nothing built for FC4-updates yet, but
rawhide versions are identical.

Comment 18 Lawrence Lim 2005-06-22 01:11:21 UTC
Tested with openoffice.org-writer-1.9.109-5.1.0.fc4 and
openoffice.org-impress-1.9.109-5.1.0.fc4, confirm the rendering, cursoring,
delete and backspace issue has been fixed. 

I am a little concern of the height of the characters though, seems to be a bit
lower than english alphabet and as a result, a small portion of the indic
characters gets cut off. Please see attached screenshot.


Thanks.

Comment 19 Lawrence Lim 2005-06-22 01:12:07 UTC
Created attachment 115790 [details]
screenshot of indic rendering in oowriter


Note You need to log in before you can comment on or make changes to this bug.