Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157809 - Dropdown list occupies the entire screen
Summary: Dropdown list occupies the entire screen
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL: http://203.18.194.16/test/longlist.html
Whiteboard:
: 165448 166965 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-16 02:50 UTC by Jesus Salvo Jr.
Modified: 2013-03-13 04:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-09 14:15:57 UTC


Attachments (Terms of Use)

Description Jesus Salvo Jr. 2005-05-16 02:50:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
If the dropdown / combo box contains a very long list, and then you click on   
the dropdown array to select from the list, the list occupies the entire   
screen ... from top to bottom, then left to right ... instead of having a   
scrollbar.   
  
I reported the problem first to kde-redhat ... since I use kde-redhat on top  
of FC3. After several testing, the culprit was  
redhat-artwork-0.121-1.0.3.kde.i386.rpm. This problem did NOT happen with the 
older redhat-artwork-0.120-0.0.3.kde.i386.rpm.  
  
It also seems to be a bug specific to BlueCurve only, since if I change the  
Style to something like "Light Style, 3rd revision", then the problem does not  
happen as well.  
  
The package maintainer of kde-redhat advised me to report this problem over  
here, since it is bluecurve specific.  

Version-Release number of selected component (if applicable):
redhat-artwork-0.122-2.1.3.kde

How reproducible:
Always

Steps to Reproduce:
1. Install kde-redhat    
2. Have at least redhat-artwork-0.121-1.0.3.kde.i386.rpm , or the latest   
redhat-artwork    
3. Go to the test URL give above.   
4. Now downgrade to redhat-artwork-0.120-0.0.3.kde.i386.rpm  
5. Go again to the test URL.  
6. Now upgrade again to the latest redhat-artworkxxxx.kde RPM 
7. Change the Style in KDE Control Centre to someting other than BlueCurve. 
8. Go again to the test URL. 
       

Actual Results:  Step 3 shows the problem 
Step 5 and 6 does NOT show the problem 

Expected Results:  Step 3 should have shown a scrollable dropdown list instead of occupying the 
entire screen. 

Additional info:

Comment 1 John (J5) Palmieri 2005-05-16 03:08:11 UTC
1. Install kde-redhat

What is kde-redhat?

If it is not comming from our offical packages I can't help.  I am assuming it
is a bug in Konqueror though you don't specify.  If this bug happens with KDE
from our packages then I may be able to help if it is coming from some other
build of Konqueror then they will have to patch their packages.

Comment 2 John (J5) Palmieri 2005-05-16 03:20:55 UTC
Closing this as WorksForMe as I have a fully updated FC3 box running Konqueror
and bluecurve which does not exibit this problem.

Comment 3 Rex Dieter 2005-05-16 11:46:13 UTC
John, can you at least see if you can confirm/deny the problem using a FC4(test)
box, since that's the (same) version of redhat-artwork Mr. Salvo is referring to.

Comment 4 John (J5) Palmieri 2005-05-16 14:11:32 UTC
I'll do that.  It was filed against FC3 so I triaged it on FC3.

Comment 5 John (J5) Palmieri 2005-05-16 15:56:40 UTC
I can now confirm the bug on the devel branch (FC4).  Might be related to this
ChangeLog:

* Wed Mar 23 2005 Than Ngo <than@redhat.com> 0.121-1
- 0.121
- Add qt Bluecurve fixes and improvements from Peter Backlund

Reopening.  Than, can you take a look at this?

Comment 6 Jesus Salvo Jr. 2005-06-07 02:32:48 UTC
Pls ? Any help I can provide ? 

Comment 7 John (J5) Palmieri 2005-06-07 02:40:24 UTC
Can you provide a patch?  I don't have time to look at this right this second. 
I cc'ed Than as he added the Bluecurve fixes that most likely broke this but I
am sure he is swamped and hasn't replyed yet.  If I get a chance after this week
I might be able to look at it but it is low in my queue.

Comment 8 Ngo Than 2005-06-07 07:25:33 UTC
it seems the improvements from Peter Backlund has caused this bug. It's on my todo  
list.

Comment 9 Ngo Than 2005-06-07 07:26:34 UTC
John, it would be nice if you could take a look here please. thanks


Comment 10 Ngo Than 2005-06-09 14:15:57 UTC
it's now fixed in redhat-artwork-0.124, which will be available in rawhide in
next day. Thanks for your report.

Comment 11 Jesus Salvo Jr. 2005-06-16 04:49:06 UTC
Using redhat-artwork-0.124 package from kde-redhat, and I can confirm that the 
problem has been fixed. 

Comment 12 Ngo Than 2005-08-09 15:36:05 UTC
*** Bug 165448 has been marked as a duplicate of this bug. ***

Comment 14 Ngo Than 2005-08-29 08:33:16 UTC
*** Bug 166965 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.