Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157802 - Need to rebuild overview after inn upgrade
Summary: Need to rebuild overview after inn upgrade
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: inn
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-16 01:14 UTC by Jonathan Kamens
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 17:06:12 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2005-05-16 01:14:24 UTC
I upgraded from inn-2.4.2-2 to inn-2.4.2-3.  Innd started segfaulting upon
startup.  It was a bear to figure out what was going on, but I finally realized
that it was segfaulting while trying to do something in the overview database. 
I erased and recreated my overview database with makehistory, and it started
working again.

I think the overview database needs to be rebuilt upon upgrade or something like
that to avoid this problem.

Comment 1 Martin Stransky 2005-05-16 13:10:06 UTC
Yes, inn-2.4.2-3 is compiled with "-D_FILE_OFFSET_BITS=64
-D_LARGEFILE_SOURCE", so it uses diferent size of types on i386 than
2.4.2-2 and the old database is unusable.

Comment 2 Martin Stransky 2005-05-16 17:05:30 UTC
The problem is with group.index, it's directly mapped w/o any check
for size. Unfortunately, group.index doesn't contain any info about
types, so I can't check it.


Note You need to log in before you can comment on or make changes to this bug.