Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157794 - iptraf configuration file removed upon reboot
Summary: iptraf configuration file removed upon reboot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iptraf
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-15 19:12 UTC by Ziga Mahkovec
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-18 13:59:19 UTC


Attachments (Terms of Use)
Patch that moves the configuration file to /etc (deleted)
2005-05-15 19:12 UTC, Ziga Mahkovec
no flags Details | Diff

Description Ziga Mahkovec 2005-05-15 19:12:18 UTC
Description of problem:
iptraf stores its configuration file in /var/run/iptraf/iptraf.cfg.  FHS issues
aside, this means that all configuration changes will be lost upon the next
reboot (since most files in /var/run are removed by rc.sysinit).

Version-Release number of selected component (if applicable):
iptraf-2.7.0-13

How reproducible:
always

Steps to Reproduce:
1. Start iptraf and change configuration.
2. Reboot.
3. Start iptraf again.
  
Actual results:
All configuration changes are lost.

Expected results:
The configuration changes should be preserved.

Additional info:
I'm attaching a patch against the package in CVS.  It moves the configuration
file to /etc/iptraf.cfg and updates the spec file and the existing documentation
patch.

Comment 1 Ziga Mahkovec 2005-05-15 19:12:18 UTC
Created attachment 114397 [details]
Patch that moves the configuration file to /etc

Comment 2 Karsten Hopp 2005-05-18 13:59:19 UTC
fixed in -15


Note You need to log in before you can comment on or make changes to this bug.