Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157778 - Inkscape hangs when opening a file
Summary: Inkscape hangs when opening a file
Keywords:
Status: CLOSED DUPLICATE of bug 156443
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Phillip Compton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-15 09:33 UTC by cameleon078
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-15 13:54:58 UTC


Attachments (Terms of Use)

Description cameleon078 2005-05-15 09:33:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
When I want to open a file, inkscape hangs and this message is written on the console :
*** glibc detected *** inkscape: free(): invalid pointer: 0x0a36c818 ***
======= Backtrace: =========
/lib/libc.so.6[0x595d1e4]
/lib/libc.so.6(__libc_free+0x77)[0x595d71f]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0x10a4669]
inkscape(_ZNSt10_List_baseIN4sigc9slot_baseESaIS1_EE8_M_clearEv+0x27)[0x80ddf69]/usr/lib/libsigc-2.0.so.0(_ZN4sigc11signal_baseD2Ev+0x47)[0x8c444d]
inkscape(_ZN8Inkscape12URIReferenceD2Ev+0x24)[0x813d8d8]
inkscape(_ZN19SPClipPathReferenceD0Ev+0x18)[0x810b0e8]
inkscape[0x81076b6]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x47)[0x776817]
/usr/lib/libgobject-2.0.so.0[0x76ad9b]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10a)[0x76b285]
/usr/lib/libgobject-2.0.so.0[0x779c96]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6ab)[0x77aee0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0x77b254]
inkscape(_Z24sp_object_invoke_releaseP8SPObject+0x94)[0x8110f9a]
inkscape[0x80dd493]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0xd2)[0x76cc54]
inkscape(_Z17sp_document_unrefP10SPDocument+0x45)[0x80db5af]
inkscape(_ZN6SPView7disposeEP8_GObject+0x11b)[0x8143b01]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0xd2)[0x76cc54]
inkscape[0x8144287]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x47)[0x776817]
/usr/lib/libgobject-2.0.so.0[0x76ad9b]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10a)[0x76b285]
/usr/lib/libgobject-2.0.so.0[0x779c96]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6ab)[0x77aee0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0x77b254]
/usr/lib/libgtk-x11-2.0.so.0[0x52c8e1]
/usr/lib/libgtk-x11-2.0.so.0[0x5ef9a5]
/usr/lib/libgobject-2.0.so.0(g_object_run_dispose+0x50)[0x76ccb4]
/usr/lib/libgtk-x11-2.0.so.0(gtk_object_destroy+0x76)[0x52c89d]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_destroy+0x41)[0x5ead1e]
inkscape(_ZN8Inkscape2UI7Dialogs10SVGPreview11setDocumentEP10SPDocument+0xac)[0x81a74dc]
inkscape(_ZN8Inkscape2UI7Dialogs10SVGPreview11setFileNameERN4Glib7ustringE+0xa6)[0x81a8002]
inkscape(_ZN8Inkscape2UI7Dialogs10SVGPreview3setERN4Glib7ustringEi+0x151)[0x81a9037]
inkscape(_ZN8Inkscape2UI7Dialogs18FileOpenDialogImpl21updatePreviewCallbackEv+0x51)[0x81a97c1]
/usr/lib/libglibmm-2.4.so.1(_ZN4Glib17SignalProxyNormal19slot0_void_callbackEP8_GObjectPv+0x46)[0x86ade6]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x47)[0x776817]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10a)[0x76b285]
/usr/lib/libgobject-2.0.so.0[0x779b04]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6ab)[0x77aee0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0xf0)[0x77da40]
/usr/lib/libgtk-x11-2.0.so.0[0x4c6bdd]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x47)[0x776817]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10a)[0x76b285]
/usr/lib/libgobject-2.0.so.0[0x77978b]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6ab)[0x77aee0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0xf0)[0x77da40]
/usr/lib/libgtk-x11-2.0.so.0[0x4c6bdd]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x47)[0x776817]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10a)[0x76b285]
/usr/lib/libgobject-2.0.so.0[0x77978b]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6ab)[0x77aee0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0xf0)[0x77da40]
/usr/lib/libgtk-x11-2.0.so.0[0x4c37fb]
/usr/lib/libgtk-x11-2.0.so.0[0x4c5456]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x47)[0x776817]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x10a)[0x76b285]
/usr/lib/libgobject-2.0.so.0[0x77978b]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6ab)[0x77aee0]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0x77b254]
/usr/lib/libgtk-x11-2.0.so.0[0x5c1498]
/usr/lib/libgtk-x11-2.0.so.0[0x5d300e]
======= Memory map: ========
00101000-0020b000 r-xp 00000000 03:06 1525009    /usr/lib/libxml2.so.2.6.19
0020b000-00213000 rwxp 00109000 03:06 1525009    /usr/lib/libxml2.so.2.6.19
00213000-00214000 rwxp 00213000 00:00 0
00214000-00219000 r-xp 00000000 03:06 1527566    /usr/lib/libpangoxft-1.0.so.0.800.1
00219000-0021a000 rwxp 00005000 03:06 1527566    /usr/l
Emergency save activated!
Processus arr�t�

Version-Release number of selected component (if applicable):
inkscape-0.41-1

How reproducible:
Always

Steps to Reproduce:
1.Start inkscape
2.Try to open a file
3.
  

Additional info:

Comment 1 Jef Spaleta 2005-05-15 13:54:58 UTC

*** This bug has been marked as a duplicate of 156443 ***


Note You need to log in before you can comment on or make changes to this bug.