Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157776 - make error with wxwidgets library
Summary: make error with wxwidgets library
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-15 09:03 UTC by Tomas Olivares
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 11:26:20 UTC


Attachments (Terms of Use)

Description Tomas Olivares 2005-05-15 09:03:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
// /usr/libexec/gcc/i386-redhat-linux/3.4.3/cc1plus -quiet -I.pch/wxprec_htmldll -Ilib/wx/include/x11univ-ansi-release-2.6 -I./include -I/usr/X11R6/include -MMD htmldll_htmlcell.d -MQ htmldll_htmlcell.o -D_GNU_SOURCE -D_REENTRANT -D__WXX11__ -D__WXUNIVERSAL__ -DWXUSINGDLL -DWXMAKINGDLL_HTML -DPIC -DWX_PRECOMP -DNO_GCC_PRAGMA -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 ./src/html/htmlcell.cpp -quiet -dumpbase htmlcell.cpp -auxbase-strip htmldll_htmlcell.o -O2 -Wall -Wno-ctor-dtor-privacy -fPIC -o - -frandom-seed=0
# 1 "./src/html/htmlcell.cpp"
# 1 "<built-in>"
# 1 "<command line>"
# 1 "./src/html/htmlcell.cpp"
# 14 "./src/html/htmlcell.cpp"
# 1 "./include/wx/wxprec.h" 1
# 13 "./include/wx/wxprec.h"
# 1 "./include/wx/defs.h" 1
# 21 "./include/wx/defs.h"
# 1 "./include/wx/platform.h" 1
# 260 "./include/wx/platform.h"
# 1 "lib/wx/include/x11univ-ansi-release-2.6/wx/setup.h" 1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download wxWidgets v2.6.0
2. Configure with "./configure --with-x11
3. run "make"
  

Actual Results:  [root@deathstar wxWidgets-2.6.0]# make
./bk-deps g++ -c -o htmldll_htmlcell.o -I.pch/wxprec_htmldll -D__WXX11__ -D__WXUNIVERSAL__           -DWXUSINGDLL -DWXMAKINGDLL_HTML -fPIC -DPIC -DWX_PRECOMP -DNO_GCC_PRAGMA -Ilib/wx/include/x11univ-ansi-release-2.6 -I./include -I/usr/X11R6/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -O2 -pthread -Wall -Wno-ctor-dtor-privacy ./src/html/htmlcell.cpp
./include/wx/x11/colour.h: In function `void SwitchSelState(wxDC&, wxHtmlRenderingInfo&, bool)':
./include/wx/x11/colour.h:59: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccMIDIAO.out file, please attach this to your bugreport.
make: *** [htmldll_htmlcell.o] Error 1

Expected Results:  No errors

Additional info:

Comment 1 Sitsofe Wheeler 2005-05-15 15:14:34 UTC
Could you attach the preprocessed source mentioned in the results
(/tmp/ccMIDIAO.out)?

Comment 2 Tomas Olivares 2005-05-15 19:20:30 UTC
Hello:

The preprocessed source of the problem is already at the "Description of Problem".

Comment 3 Mike A. Harris 2005-05-16 14:57:32 UTC
(In reply to comment #0)

> Actual Results:  [root@deathstar wxWidgets-2.6.0]# make
> ./bk-deps g++ -c -o htmldll_htmlcell.o -I.pch/wxprec_htmldll -D__WXX11__
-D__WXUNIVERSAL__           -DWXUSINGDLL -DWXMAKINGDLL_HTML -fPIC -DPIC
-DWX_PRECOMP -DNO_GCC_PRAGMA -Ilib/wx/include/x11univ-ansi-release-2.6
-I./include -I/usr/X11R6/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES
-D_LARGEFILE_SOURCE=1 -O2 -pthread -Wall -Wno-ctor-dtor-privacy
./src/html/htmlcell.cpp
> ./include/wx/x11/colour.h: In function `void SwitchSelState(wxDC&,
wxHtmlRenderingInfo&, bool)':
> ./include/wx/x11/colour.h:59: internal compiler error: Segmentation fault
                                ^^^^^^^^^^^^^^^^^^^^^^^

Why is this filed against XFree86 (which doesn't even exist in Fedora Core)?
This is an compiler bug, as the above error indicates.

> Please submit a full bug report,
> with preprocessed source if appropriate.
> See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
> Preprocessed source stored into /tmp/ccMIDIAO.out file,
> please attach this to your bugreport.
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

This means to attach the files directly to the bug report as a bugzilla
file attachment.

>Hello:
>
>The preprocessed source of the problem is already at the "Description of >Problem".

Which is insufficient, because the information is not being tracked directly
in the bug report then, and could vanish off the linked URL at any time in
the future, leaving the bug report devoid of information useful to
fixing the problem.

File attachments must be directly attached using the "Create an attachment
link" below.

Thanks in advance.

Reassigning to correct component (gcc), and setting bug in "NEEDINFO"
state, awaiting file attachments.



Comment 4 Jakub Jelinek 2005-05-17 11:58:57 UTC
Are you sure you pasted the whole file?  It looks like you only pasted 13 lines
from the beginning of a much larger file.

Comment 5 Jakub Jelinek 2005-06-13 16:13:34 UTC
I'll close this bug soon unless the full attachment is provided.


Note You need to log in before you can comment on or make changes to this bug.