Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157771 - yaboot, Cann't load "second stage bootstrap"
Summary: yaboot, Cann't load "second stage bootstrap"
Keywords:
Status: CLOSED DUPLICATE of bug 158026
Alias: None
Product: Fedora
Classification: Fedora
Component: yaboot
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-15 01:47 UTC by TAIRA Hajime
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-18 14:23:17 UTC


Attachments (Terms of Use)

Description TAIRA Hajime 2005-05-15 01:47:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; ja-jp) AppleWebKit/312.1 (KHTML, like Gecko) Safari/312

Description of problem:
I completed install fc4t3-ppc on PowerMac G3 B&W.
After reboot system. yaboot cann't load "second stage bootstrap".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install fc4t3.
2.reboot
  

Additional info:

Comment 1 Paul Nasrat 2005-05-16 12:34:30 UTC
Can you boot into OF (cmd option O F)

printenv boot-device

Comment 2 TAIRA Hajime 2005-05-16 13:59:10 UTC
Sorry, Already I Installed Yellow Dog Linux 4 into HDD.
Now I executed printenv command.
Here is output message.

0 > printenv boot-device
------------ Partition: common -------- Signature: 0x70 ----------------
boot-device                 /pci@80000000/pci-bridge@d/pci-ata@1/@0/disk@0:2,¥¥:tbxi hd:,¥¥:tbxi
 ok

2month ago, I succeeded in installation of "Unofficial Fedora Core 3 PPC".
I can boot kernel.

Comment 3 Paul Nasrat 2005-05-16 14:17:26 UTC
Can I assume it actually reads \\ rather than ¥¥ - eg hd:,\\:tbxi

If yellow dog can boot the machine using yaboot, we should be able to.  If
you've overwritten the install which will have updated the nvram I can't really
diagnose this.  

If fc3 worked and ydl worked I can't see why fc4t3 would have failed, could you
try another install?

Comment 4 TAIRA Hajime 2005-05-16 14:38:26 UTC
> If you've overwritten the install which will have updated the nvram I can't really diagnose this.  

I think so.

> could you try another install?

When I have time, I will try installation of fc4t3.

Comment 5 Paul Nasrat 2005-05-18 14:13:18 UTC
I believe this to be a duplicate of 157771 which can be worked around by setting
to boot off the yaboot binary. 

I believe this to be an issue with your OF version and the ofboot.b script.  
Please ensure you are running most recent firmware update and note your firmware
version in the bug

http://docs.info.apple.com/article.html?artnum=86117

Please can you attach a listing of yellowdog's boot partition:

mount -t hfs /dev/hda2 /mnt
ls /mnt

Could you also attach their ofboot.b script.

Comment 6 Paul Nasrat 2005-05-18 14:23:17 UTC
Correction related bug #158026  I'm closing this one as the other one has more
debugging, please add details requested above to that bug.

*** This bug has been marked as a duplicate of 158026 ***


Note You need to log in before you can comment on or make changes to this bug.