Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157769 - Boost complains the compiler is too new.
Summary: Boost complains the compiler is too new.
Keywords:
Status: CLOSED DUPLICATE of bug 153093
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-14 22:47 UTC by yuubyou+rhbz
Modified: 2013-08-09 05:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 15:15:05 UTC


Attachments (Terms of Use)

Description yuubyou+rhbz 2005-05-14 22:47:13 UTC
Description of problem:
When compiling an application that uses Boost, I get many warnings of the
following form:
In file included from /usr/include/boost/config.hpp:35,
                 from /usr/include/boost/detail/iterator.hpp:53,
                 from /usr/include/boost/array.hpp:32,
                 from foo.cc:1:
/usr/include/boost/config/compiler/gcc.hpp:92:7: warning: #warning "Unknown
compiler version - please run the configure tests and report the results"


Version-Release number of selected component (if applicable):

boost-1.32.0-3
gcc-4.0.0-2

How reproducible:
always

Steps to Reproduce:
1. echo '#include <boost/array.hpp>' > foo.cc
2. gcc -c foo.cc
  
Actual results:
warning message as above

Expected results:
silent success

Additional info:
As the program did link and work, I assume Boost was built with gcc 4.  g++32
can't even generate binaries (bug 157654), so the library probably wasn't built
with that.

Comment 1 Benjamin Kosnik 2005-05-24 15:15:05 UTC

*** This bug has been marked as a duplicate of 153093 ***


Note You need to log in before you can comment on or make changes to this bug.