Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157758 - ssh-agent does not appear to work
Summary: ssh-agent does not appear to work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-14 16:09 UTC by David Bloomfield
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-14 16:37:13 UTC


Attachments (Terms of Use)

Description David Bloomfield 2005-05-14 16:09:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Ever since I upgraded from Fedora Core 3 to FC4 test2 ssh-agent has not worked. I was hoping upgrading to test3 would help but it doesn't look like the packages have changed so I thought I'd better report this. I use ssh-agent all the time with a SSH v1 key. I use KDE as my window manager and I am prompted for the ssh passphrase after login but before any other windows open, as I would expect. Below is the ssh-agent process running on my linux box, i'm pretty sure the version that came with Fedora Core 3 didn't have the dbus option on the command line, maybe something to do with this?

"/usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /home/davidbl/.Xclients"

from .bash_profile:

eval `ssh-agent`
eval `ssh-add`

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use FC4 test2 or test3 (haven't tested on test1)
2. setup ssh-agent in .bash_profile and make sure your key is present in .ssh/identity and .ssh/identity.pub
3. Login to computer using kde session
4. Connect using "ssh -1" to a user@host that has your key in authorized_keys
  

Actual Results:  I'm prompted for my password when I shouldn't be

Expected Results:  Should have been logged in automatically.

Additional info:

Comment 1 David Bloomfield 2005-05-14 16:36:06 UTC
A colleague has now pointed out that a second instance of ssh-agent is being
started everytime I log-in, I've commented out the eval lines from my
.bash_profile and am now starting ssh-agent from ~/.kde/Autostart

my issue is resolved, sorry if I wasted anyone's time.
David.


Note You need to log in before you can comment on or make changes to this bug.