Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157751 - Unable to launch Ant editor
Summary: Unable to launch Ant editor
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-14 15:09 UTC by Mary Ellen Foster
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 19:30:06 UTC


Attachments (Terms of Use)
Simple build.xml file demonstrating the problem (deleted)
2005-05-14 15:09 UTC, Mary Ellen Foster
no flags Details

Description Mary Ellen Foster 2005-05-14 15:09:36 UTC
Description of problem:

I'm unable to load even the simplest Ant build file into the Ant editor in
Eclipse. I'll attach a very simple one that I created to test a different Ant
bug; even this one doesn't work. I moved my "workspace" directory out of the way
to be sure it wasn't some old configuration hanging around.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.16

How reproducible:
Every time

Steps to Reproduce:
1. Load the attached build.xml file into eclipse
  
Actual results:
Screen says:Unable to create editor. This message may be due to a bug in the
editor, not a problem with the file you are trying to edit. First close this
error message and then use "Open With..." to open the file in a different
editor. Reason for the failure: Editor could not be initialized.

There's also "Details" button; when I press it, I get the following backtrace:
java.lang.NoClassDefFoundError: org/eclipse/ant/core/AntSecurityException
	at
org.eclipse.ant.internal.ui.editor.text.AntEditorDocumentProvider.createAntModel(AntEditorDocumentProvider.java:70)
	at
org.eclipse.ant.internal.ui.editor.text.AntEditorDocumentProvider.createFileInfo(AntEditorDocumentProvider.java:114)
	at
org.eclipse.ui.editors.text.TextFileDocumentProvider.connect(TextFileDocumentProvider.java:463)
	at
org.eclipse.ui.texteditor.AbstractTextEditor.doSetInput(AbstractTextEditor.java:2993)
	at org.eclipse.ui.texteditor.StatusTextEditor.doSetInput(StatusTextEditor.java:173)
	at
org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.doSetInput(AbstractDecoratedTextEditor.java:1253)
	at org.eclipse.ui.editors.text.TextEditor.doSetInput(TextEditor.java:262)
	at org.eclipse.ant.internal.ui.editor.AntEditor.doSetInput(AntEditor.java:858)
	at
org.eclipse.ui.texteditor.AbstractTextEditor$16.run(AbstractTextEditor.java:2345)
	at
org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)
	at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:291)
	at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:624)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
	at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:621)
	at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:1975)
	at
org.eclipse.ui.texteditor.AbstractTextEditor.internalInit(AbstractTextEditor.java:2363)
	at org.eclipse.ui.texteditor.AbstractTextEditor.init(AbstractTextEditor.java:2390)
	at org.eclipse.ui.internal.EditorManager.createSite(EditorManager.java:857)
	at
org.eclipse.ui.internal.EditorManager.busyRestoreEditorHelper(EditorManager.java:1223)
	at org.eclipse.ui.internal.EditorManager.busyRestoreEditor(EditorManager.java:1102)
	at org.eclipse.ui.internal.EditorManager$7.run(EditorManager.java:1064)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
	at org.eclipse.ui.internal.EditorManager.restoreEditor(EditorManager.java:1062)
	at org.eclipse.ui.internal.EditorManager$Editor.getEditor(EditorManager.java:1648)
	at org.eclipse.ui.internal.EditorManager$Editor.getPart(EditorManager.java:1639)
	at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:260)
	at
org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:126)
	at
org.eclipse.ui.internal.presentations.newapi.PresentablePartFolder.select(PresentablePartFolder.java:268)
	at
org.eclipse.ui.internal.presentations.newapi.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
	at
org.eclipse.ui.internal.presentations.newapi.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:391)
	at
org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1070)
	at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1019)
	at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1223)
	at org.eclipse.ui.internal.PartStack.add(PartStack.java:406)
	at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:109)
	at
org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)
	at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:267)
	at org.eclipse.ui.internal.EditorManager$4.run(EditorManager.java:829)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
	at org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:809)
	at
org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:697)
	at org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:660)
	at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2236)
	at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2165)
	at org.eclipse.ui.internal.WorkbenchPage.access$7(WorkbenchPage.java:2157)
	at org.eclipse.ui.internal.WorkbenchPage$9.run(WorkbenchPage.java:2143)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
	at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2138)
	at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2123)
	at
org.eclipse.ui.internal.editors.text.OpenExternalFileAction.run(OpenExternalFileAction.java:124)
	at
org.eclipse.ui.internal.editors.text.OpenExternalFileAction.run(OpenExternalFileAction.java:93)
	at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:246)
	at org.eclipse.ui.internal.WWinPluginAction.runWithEvent(WWinPluginAction.java:220)
	at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
	at
org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
	at
org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:82)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1012)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2778)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2472)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1570)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1534)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:306)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
	at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
	at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:228)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:156)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.core.launcher.Main.invokeFramework(Main.java:315)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:268)
	at org.eclipse.core.launcher.Main.run(Main.java:942)
	at org.eclipse.core.launcher.Main.main(Main.java:926)



Expected results:
The file would be loaded into an Ant editor in eclipse.

Additional info:
I also have the jpackage.org 1.4.2 and 1.5.0 JSDK rpms installed on this machine.

Comment 1 Mary Ellen Foster 2005-05-14 15:09:36 UTC
Created attachment 114383 [details]
Simple build.xml file demonstrating the problem

Comment 2 Mary Ellen Foster 2005-05-18 21:50:12 UTC
Note that the above back trace was using Sun JSDK 1.5.0_02 (packaged by
JPackage) as by /usr/bin/java. If I switch to GCJ, the backtrace is different:

java.lang.NoClassDefFoundError: while resolving class:
org.eclipse.ant.internal.ui.model.AntModel
   at java.lang.VMClassLoader.transformException(java.lang.Class,
java.lang.Throwable) (/usr/lib/libgcj.so.6.0.0)
   at java.lang.VMClassLoader.resolveClass(java.lang.Class)
(/usr/lib/libgcj.so.6.0.0)
   at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
   at
org.eclipse.ant.internal.ui.editor.text.AntEditorDocumentProvider.createAntModel(java.lang.Object,
org.eclipse.jface.text.IDocument,
org.eclipse.jface.text.source.IAnnotationModel)
(/usr/lib/eclipse/plugins/org.eclipse.ant.ui_3.1.0/antui.jar.so)
   at
org.eclipse.ant.internal.ui.editor.text.AntEditorDocumentProvider.createFileInfo(java.lang.Object)
(/usr/lib/eclipse/plugins/org.eclipse.ant.ui_3.1.0/antui.jar.so)
   at
org.eclipse.ui.editors.text.TextFileDocumentProvider.connect(java.lang.Object)
(/usr/lib/eclipse/plugins/org.eclipse.ui.editors_3.1.0/editors.jar.so)
   at
org.eclipse.ui.texteditor.AbstractTextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.texteditor.StatusTextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.editors_3.1.0/editors.jar.so)
   at
org.eclipse.ui.editors.text.TextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.editors_3.1.0/editors.jar.so)
   at
org.eclipse.ant.internal.ui.editor.AntEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ant.ui_3.1.0/antui.jar.so)
   at
org.eclipse.ui.texteditor.AbstractTextEditor$16.run(org.eclipse.core.runtime.IProgressMonitor)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.jface.operation.ModalContext.runInCurrentThread(org.eclipse.jface.operation.IRunnableWithProgress,
org.eclipse.core.runtime.IProgressMonitor)
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at
org.eclipse.jface.operation.ModalContext.run(org.eclipse.jface.operation.IRunnableWithProgress,
boolean, org.eclipse.core.runtime.IProgressMonitor,
org.eclipse.swt.widgets.Display)
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at org.eclipse.jface.window.ApplicationWindow$1.run()
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.widgets.Display,
java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.swt.gtk_3.1.0.jar.so)
   at org.eclipse.jface.window.ApplicationWindow.run(boolean, boolean,
org.eclipse.jface.operation.IRunnableWithProgress)
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at org.eclipse.ui.internal.WorkbenchWindow.run(boolean, boolean,
org.eclipse.jface.operation.IRunnableWithProgress) (Unknown Source)
   at
org.eclipse.ui.texteditor.AbstractTextEditor.internalInit(org.eclipse.ui.IWorkbenchWindow,
org.eclipse.ui.IEditorSite, org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.texteditor.AbstractTextEditor.init(org.eclipse.ui.IEditorSite,
org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.internal.EditorManager.createSite(org.eclipse.ui.IEditorReference,
org.eclipse.ui.IEditorPart, org.eclipse.ui.internal.registry.EditorDescriptor,
org.eclipse.ui.IEditorInput) (Unknown Source)
   at
org.eclipse.ui.internal.EditorManager.busyRestoreEditorHelper(org.eclipse.ui.internal.EditorManager$Editor)
(Unknown Source)
   at
org.eclipse.ui.internal.EditorManager.busyRestoreEditor(org.eclipse.ui.internal.EditorManager$Editor)
(Unknown Source)
   at org.eclipse.ui.internal.EditorManager$7.run() (Unknown Source)
   at
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.widgets.Display,
java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.swt.gtk_3.1.0.jar.so)
   at
org.eclipse.ui.internal.EditorManager.restoreEditor(org.eclipse.ui.internal.EditorManager$Editor)
(Unknown Source)
   at org.eclipse.ui.internal.EditorManager$Editor.getEditor(boolean) (Unknown
Source)
   at org.eclipse.ui.internal.EditorManager$Editor.getPart(boolean) (Unknown Source)
   at org.eclipse.ui.internal.PartPane.setVisible(boolean) (Unknown Source)
   at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(boolean)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.newapi.PresentablePartFolder.select(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.newapi.LeftToRightTabOrder.select(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.newapi.TabbedStackPresentation.selectPart(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at org.eclipse.ui.internal.PartStack.refreshPresentationSelection() (Unknown
Source)
   at
org.eclipse.ui.internal.PartStack.setSelection(org.eclipse.ui.internal.LayoutPart)
(Unknown Source)
   at
org.eclipse.ui.internal.PartStack.showPart(org.eclipse.ui.internal.LayoutPart,
java.lang.Object) (Unknown Source)
   at org.eclipse.ui.internal.PartStack.add(org.eclipse.ui.internal.LayoutPart)
(Unknown Source)
   at
org.eclipse.ui.internal.EditorStack.add(org.eclipse.ui.internal.LayoutPart)
(Unknown Source)
   at
org.eclipse.ui.internal.EditorSashContainer.addEditor(org.eclipse.ui.internal.EditorPane)
(Unknown Source)
   at
org.eclipse.ui.internal.EditorAreaHelper.addToLayout(org.eclipse.ui.internal.EditorPane)
(Unknown Source)
Caused by: java.lang.ClassNotFoundException:
org.eclipse.ant.internal.core.AntSecurityManager
   at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String,
boolean) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(java.lang.String)
(/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at
org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(java.lang.String,
boolean) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at java.lang.ClassLoader.loadClass(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at java.lang.VMClassLoader.resolveClass(java.lang.Class)
(/usr/lib/libgcj.so.6.0.0)
   at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
   at
org.eclipse.ant.internal.ui.editor.text.AntEditorDocumentProvider.createAntModel(java.lang.Object,
org.eclipse.jface.text.IDocument,
org.eclipse.jface.text.source.IAnnotationModel)
(/usr/lib/eclipse/plugins/org.eclipse.ant.ui_3.1.0/antui.jar.so)
   at
org.eclipse.ant.internal.ui.editor.text.AntEditorDocumentProvider.createFileInfo(java.lang.Object)
(/usr/lib/eclipse/plugins/org.eclipse.ant.ui_3.1.0/antui.jar.so)
   at
org.eclipse.ui.editors.text.TextFileDocumentProvider.connect(java.lang.Object)
(/usr/lib/eclipse/plugins/org.eclipse.ui.editors_3.1.0/editors.jar.so)
   at
org.eclipse.ui.texteditor.AbstractTextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.texteditor.StatusTextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.editors_3.1.0/editors.jar.so)
   at
org.eclipse.ui.editors.text.TextEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.editors_3.1.0/editors.jar.so)
   at
org.eclipse.ant.internal.ui.editor.AntEditor.doSetInput(org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ant.ui_3.1.0/antui.jar.so)
   at
org.eclipse.ui.texteditor.AbstractTextEditor$16.run(org.eclipse.core.runtime.IProgressMonitor)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.jface.operation.ModalContext.runInCurrentThread(org.eclipse.jface.operation.IRunnableWithProgress,
org.eclipse.core.runtime.IProgressMonitor)
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at
org.eclipse.jface.operation.ModalContext.run(org.eclipse.jface.operation.IRunnableWithProgress,
boolean, org.eclipse.core.runtime.IProgressMonitor,
org.eclipse.swt.widgets.Display)
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at org.eclipse.jface.window.ApplicationWindow$1.run()
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.widgets.Display,
java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.swt.gtk_3.1.0.jar.so)
   at org.eclipse.jface.window.ApplicationWindow.run(boolean, boolean,
org.eclipse.jface.operation.IRunnableWithProgress)
(/usr/lib/eclipse/plugins/org.eclipse.jface_3.1.0.jar.so)
   at org.eclipse.ui.internal.WorkbenchWindow.run(boolean, boolean,
org.eclipse.jface.operation.IRunnableWithProgress) (Unknown Source)
   at
org.eclipse.ui.texteditor.AbstractTextEditor.internalInit(org.eclipse.ui.IWorkbenchWindow,
org.eclipse.ui.IEditorSite, org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.texteditor.AbstractTextEditor.init(org.eclipse.ui.IEditorSite,
org.eclipse.ui.IEditorInput)
(/usr/lib/eclipse/plugins/org.eclipse.ui.workbench.texteditor_3.1.0/texteditor.jar.so)
   at
org.eclipse.ui.internal.EditorManager.createSite(org.eclipse.ui.IEditorReference,
org.eclipse.ui.IEditorPart, org.eclipse.ui.internal.registry.EditorDescriptor,
org.eclipse.ui.IEditorInput) (Unknown Source)
   at
org.eclipse.ui.internal.EditorManager.busyRestoreEditorHelper(org.eclipse.ui.internal.EditorManager$Editor)
(Unknown Source)
   at
org.eclipse.ui.internal.EditorManager.busyRestoreEditor(org.eclipse.ui.internal.EditorManager$Editor)
(Unknown Source)
   at org.eclipse.ui.internal.EditorManager$7.run() (Unknown Source)
   at
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.widgets.Display,
java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.swt.gtk_3.1.0.jar.so)
   at
org.eclipse.ui.internal.EditorManager.restoreEditor(org.eclipse.ui.internal.EditorManager$Editor)
(Unknown Source)
   at org.eclipse.ui.internal.EditorManager$Editor.getEditor(boolean) (Unknown
Source)
   at org.eclipse.ui.internal.EditorManager$Editor.getPart(boolean) (Unknown Source)
   at org.eclipse.ui.internal.PartPane.setVisible(boolean) (Unknown Source)
   at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(boolean)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.newapi.PresentablePartFolder.select(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.newapi.LeftToRightTabOrder.select(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at
org.eclipse.ui.internal.presentations.newapi.TabbedStackPresentation.selectPart(org.eclipse.ui.presentations.IPresentablePart)
(Unknown Source)
   at org.eclipse.ui.internal.PartStack.refreshPresentationSelection() (Unknown
Source)
   at
org.eclipse.ui.internal.PartStack.setSelection(org.eclipse.ui.internal.LayoutPart)
(Unknown Source)
   at
org.eclipse.ui.internal.PartStack.showPart(org.eclipse.ui.internal.LayoutPart,
java.lang.Object) (Unknown Source)
   at org.eclipse.ui.internal.PartStack.add(org.eclipse.ui.internal.LayoutPart)
(Unknown Source)
   at
org.eclipse.ui.internal.EditorStack.add(org.eclipse.ui.internal.LayoutPart)
(Unknown Source)


Comment 3 Mary Ellen Foster 2005-05-18 22:04:46 UTC
Note that this still happens with the newest eclipse,
eclipse-platform-3.1.0_fc-0.M6.18.

Comment 4 Andrew Overholt 2005-05-18 22:08:27 UTC
If this happens with both a Sun JVM and with gcj, I'm inclined to believe it's
an upstream issue.  Can you duplicate with an upstream M6 build [1]?

[1]
http://download.eclipse.org/eclipse/downloads/drops/S-3.1M6-200504011645/index.php

Comment 5 Mary Ellen Foster 2005-05-18 22:45:13 UTC
Nope; works fine with the upstream Eclipse.

Here's what I'm doing:
- Run eclipse (either "/usr/bin/eclipse" or "./eclipse" in the directory where I
 uncompressed the above upstream tarball)
- "File"-"Open external file" and open the build.xml I attached to this bug report

With the upstream M6 build, it opens successfully in the Ant editor, whether
/usr/bin/java points to GCJ or Sun; with the Rawhide eclipse, it fails with
either VM, with the backtraces I've included.

Is this just me? Can other people open the attached file in Eclipse successfully?

Comment 6 Mary Ellen Foster 2005-05-23 19:30:06 UTC
Okay, whether it was today's Rawhide eclipse update, or the fact that I
accidentally blew away my /home partition and started with a completely clean
config, I can now open build.xml files in eclipse again.


Note You need to log in before you can comment on or make changes to this bug.