Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157743 (IT_72829) - Traceback, system-config-lvm shows incorrect size values
Summary: Traceback, system-config-lvm shows incorrect size values
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: IT_72829
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact:
URL:
Whiteboard:
: 157740 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-14 12:21 UTC by Uwe Beck
Modified: 2009-04-16 23:11 UTC (History)
3 users (show)

Fixed In Version: 1.0.16-1.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-19 02:32:36 UTC


Attachments (Terms of Use)
system-config-lvm.png from bug 157740 (deleted)
2005-05-16 14:42 UTC, Suzanne Hillman
no flags Details

Description Uwe Beck 2005-05-14 12:21:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050422 Red Hat/1.7.7-1.4.2

Description of problem:
# fdisk -l /dev/sda

Platte /dev/sda: 9100 MByte, 9100369920 Byte
255 K�pfe, 63 Sektoren/Spuren, 1106 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes

    Ger�t Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          10       80293+  83  Linux
/dev/sda2              11        1106     8803620   8e  Linux LVM

# lvscan
  ACTIVE            '/dev/rootvg/rootlv' [7,34 GB] inherit
  ACTIVE            '/dev/rootvg/swaplv' [1,00 GB] inherit

system-config-lvm means "Available Space: 38 GB"

Traceback is the result only from list operations in system-config-lvm.

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 303, in on_tree_selection_changed
    self.vr.render(pv_list, 0)
  File "/usr/share/system-config-lvm/renderer.py", line 150, in render
    self.divide_volume(self.viewable_vols)
  File "/usr/share/system-config-lvm/renderer.py", line 1202, in divide_volume
    extent_multiplier = operator.div(span, total)
ZeroDivisionError: float division

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.18-1.0

How reproducible:
Always

Steps to Reproduce:
1. start system-config-lvm
2. list your VGs anl LVs
3. see the difference between real phyical hdd size (fdisk) and output from system-config-lvm
  

Actual Results:  Available Space: incorrect size value

Expected Results:  Available Space: correct size value

Additional info:

known since Bugzilla #139903 (choise of system-config-lvm was not available on 2004-11-18)

Comment 1 Suzanne Hillman 2005-05-16 14:42:05 UTC
Created attachment 114424 [details]
system-config-lvm.png from bug 157740

Comment 2 Suzanne Hillman 2005-05-16 14:42:37 UTC
*** Bug 157740 has been marked as a duplicate of this bug. ***

Comment 3 Stanko Kupcevic 2005-05-16 20:32:33 UTC
Fixed in 0.9.27

Comment 7 David Lawrence 2006-07-18 02:51:31 UTC
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.


Note You need to log in before you can comment on or make changes to this bug.