Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157731 - netstat seems to be <defunct> for no reason
Summary: netstat seems to be <defunct> for no reason
Keywords:
Status: CLOSED DUPLICATE of bug 101221
Alias: None
Product: Fedora
Classification: Fedora
Component: net-tools
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-14 08:34 UTC by hipodilski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 07:49:46 UTC


Attachments (Terms of Use)

Description hipodilski 2005-05-14 08:34:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
Hi there on fedora core 3. I experience a problem concerning netstat. I see it as defunct when trying to take a look at my processes. I'm up2date with all updates from redhat. And currently i have running Ximian xmms a wine application and a mozilla browser. I have no idea what causes the defunct, but i'm seeing this problem since fedora core 1. And i guess the problem needs to be fixed.
[hipo@davidian ~]$ ps axu | grep netstat
hipo      8087  0.0  0.0     0    0 ?        Z    09:45   0:00 [netstat] <defunct>
hipo      8257  0.0  0.0     0    0 ?        Z    10:25   0:00 [netstat] <defunct>
hipo      8568  0.0  0.1  4676  660 pts/9    S+   11:32   0:00 grep netstat
[hipo@davidian ~]$
[hipo@davidian ~]$ uname -a;
Linux davidian 2.6.9-1.667 #1 Tue Nov 2 14:41:25 EST 2004 i686 athlon i386 GNU/Linux
[hipo@davidian ~]$


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. A regular default install
2. 
3.
  

Actual Results:  netstat in the process list seeming as defunct with nothing really running netstat

Additional info:

Comment 1 Radek Vokal 2005-05-15 09:34:33 UTC
This is usually caused by mozilla. Please try to stop all mozilla processes and
grep them again. If this doesn't help, try to figure out which process causes
this disfunction. 

Comment 2 hipodilski 2005-05-16 07:26:44 UTC
Yes the <defunct> netstat is a subprocess spawned by mozilla. Anyway there is
then a problem with mozilla or? I'm running mozilla under debian and slackware
and i don't see <defunct> netstats there?. Is a <defunct> zoombie process
something normal under linux? I don't think so ....

Comment 3 Radek Vokal 2005-05-16 07:49:46 UTC

*** This bug has been marked as a duplicate of 101221 ***


Note You need to log in before you can comment on or make changes to this bug.