Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157722 - Building updated distribution using symbolic link
Summary: Building updated distribution using symbolic link
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-14 02:42 UTC by David Kuestler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 14:00:41 UTC


Attachments (Terms of Use)

Description David Kuestler 2005-05-14 02:42:53 UTC
Description of problem:
When updating or adding extra packages to a standard distribution the standard
distribution can only be a directory instead of a symbolic link.

Version-Release number of selected component (if applicable):
long standing problem - all versions ;-)

How reproducible:
Copy a standard distribution to a subdirectory and  make a symbolic link to this
subdirectory from a build directory.

Steps to Reproduce:
1. Copy a standard distribution to a subdirectory.
2. Make a symbolic link to this subdirectory from a build directory.
3. Try to build a new distribution.
  
Actual results:
The symbolic linked directory is not recognised.

Expected results:
The symbolic link behaves as a subdirectory.

Additional info:
The problem is caused by the 'find' command not descending a subdirectory if it
is a symbolic link.
The fix is to add a '/' to the 'find' command syntax.
Patch :
diff -urN anaconda-10.2.0.47.orig/scripts/splittree.py
anaconda-10.2.0.47/scripts/splittree.py
--- anaconda-10.2.0.47.orig/scripts/splittree.py	2005-04-01 09:16:56.000000000 +1000
+++ anaconda-10.2.0.47/scripts/splittree.py	2005-04-16 09:52:58.977919347 +1000
@@ -199,12 +199,12 @@
 
         for i in range(self.bin_list[0], self.bin_list[-1] + 1):
             if i == 1:
-                p = os.popen('find %s -type f -not -name .discinfo' %
self.dist_dir, 'r')
+                p = os.popen('find %s/ -type f -not -name .discinfo' %
self.dist_dir, 'r')
                 filelist = p.read()
                 p.close()
                 filelist = string.split(filelist)
                 
-                p = os.popen('find %s -type d -not -name RPMS -not -name SRPMS'
% self.dist_dir, 'r')
+                p = os.popen('find %s/ -type d -not -name RPMS -not -name
SRPMS' % self.dist_dir, 'r')
                 dirlist = p.read()
                 p.close()
                 dirlist = string.split(dirlist)

Comment 1 Chris Lumens 2005-05-16 14:00:41 UTC
Fixed in CVS.  Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.