Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157716 - New Rhythmbox bluecurve theme
Summary: New Rhythmbox bluecurve theme
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL: http://www.digitalprognosis.com/opens...
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-14 00:26 UTC by Jeff Schroeder
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-14 13:53:25 UTC


Attachments (Terms of Use)
16x16 (deleted)
2005-05-27 16:47 UTC, diana fong
no flags Details
24x24 (deleted)
2005-05-27 16:49 UTC, diana fong
no flags Details
48x48 (deleted)
2005-05-27 16:49 UTC, diana fong
no flags Details
96x96 (deleted)
2005-05-27 16:49 UTC, diana fong
no flags Details

Description Jeff Schroeder 2005-05-14 00:26:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050512 Firefox/1.0 (Ubuntu package 1.0.2)

Description of problem:
I just made a pretty nice bluecurve icon theme for rhythmbox. Integration is important in a modern / professional Linux distribution and this allows the music player to fit right in with the desktop icons.

http://www.digitalprognosis.com/opensource/iconsheet-rhythmbox.png Before
http://www.digitalprognosis.com/opensource/iconsheet-bluecurve.png After
http://www.digitalprognosis.com/opensource/rhythmbox-bluecurve.tar.gz Download

You need to extract the tarball into /opt/gnome/share/rhythmbox/art/ to get the desired effect.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install fedora and rhythmbox isn't bluecurve themed.

Additional info:

Comment 1 Colin Walters 2005-05-27 15:13:28 UTC
Hi Jeff,

Sorry about taking so long to process this.  I had a closer look; some specific
comments:

1) The playback cursor appears corrupt here:
   http://verbum.org/files/Rhythmbox-corrupt-playback.png
   Are you seeing this as well?  I think it might be a problem in the source;
   we do some tricks on the icon to invert it for selection.
2) The old internet radio icon, being a satellite, conveyed some sense of 
   "radio".  The new icon (a speaker) does not.  Perhaps not a big deal.
3) The new notification area icon looks rather fuzzy; it stands in contrast
   to most of the other notification area icons I have now:
   http://verbum.org/files/Rhythmbox-newtray.png

Comment 2 diana fong 2005-05-27 16:32:26 UTC
For comment #2, the speaker icon seems alright.  However, I can create a new
icon for it...suggests tower with signals emanating from it. What size should
that be?  Should it come invarious sizes...ie, 16x16, 24x24, etc?

Comment #3.  I believe it's fuzzy because the image Colin's using is only 16x16
and the panel icons are 24x24.  I will attach larger Bluecurve icons...Jeff, not
sure if you need them in sizes other than 24x24, but will include anyway.

Comment 3 diana fong 2005-05-27 16:47:41 UTC
Created attachment 114917 [details]
16x16

Comment 4 diana fong 2005-05-27 16:49:00 UTC
Created attachment 114918 [details]
24x24

Take out the number before Rythmbox-newtray if you use any of the icons.
Thanks

Comment 5 diana fong 2005-05-27 16:49:17 UTC
Created attachment 114919 [details]
48x48

Comment 6 diana fong 2005-05-27 16:49:36 UTC
Created attachment 114920 [details]
96x96

Comment 7 Jeff Schroeder 2005-05-28 00:01:10 UTC
The star icon does the same thing as the playback icon but I'm not sure what needs
to be done to properly invert it.
http://www.digitalprognosis.com/opensource/rhythmbox-bluecurve.png

Also, there isn't a suitable bluecurve ipod icon so I just left the stock one. If
you have an eye for perfection, you'll notice that it doesn't quite fit in. The
new tray icons look good by the way.

Comment 8 Colin Walters 2005-06-13 22:43:37 UTC
I've fixed the rendering issues and am building a new rhythmbox now, should
hopefully appear in rawhide tomorrow.


Note You need to log in before you can comment on or make changes to this bug.