Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157679 - Application hangs during startup because of Esound troubles
Summary: Application hangs during startup because of Esound troubles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: foobillard
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 17:50 UTC by Jacob Kroon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-04 15:25:22 UTC


Attachments (Terms of Use)

Description Jacob Kroon 2005-05-13 17:50:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050506 Fedora/1.7.7-4

Description of problem:
Running the game the first time on a boot (and perhaps the first after a login) works fine, but running it another time leaves the screen blank, and the program hangs. Stracing it reveals that it hangs about the time when it tries to read ESound-lock files in /tmp. Exporting SDL_AUDIODRIVER=dsp before running the application is a workaround that works. Perhaps Foobillard should be patched to use this audiodriver specifically. Or it could be that this affects all applications that is using SDL. _Or_ it could just be related to the other problems I'm having with using the Alsa/dmix plugin...

Version-Release number of selected component (if applicable):
foobillard-3.0a-2

How reproducible:
Always

Steps to Reproduce:
(null)  

Additional info:

Comment 1 Jacob Kroon 2005-05-13 17:53:30 UTC
Sorry I forgot to add CR's in the bug comments. Here it is again in a more
reader-friendly format:

Running the game the first time on a boot (and perhaps the first after a login)
works fine, but running it another time leaves the screen blank, and the program
hangs. Stracing it reveals that it hangs about the time when it tries to read
ESound-lock files in /tmp. Exporting SDL_AUDIODRIVER=dsp before running the
application is a workaround that works. Perhaps Foobillard should be patched to
use this audiodriver specifically. Or it could be that this affects all
applications that is using SDL. _Or_ it could just be related to the other
problems I'm having with using the Alsa/dmix plugin...

Comment 2 Jacob Kroon 2005-05-25 14:35:50 UTC
I can't reproduce this bug anymore with alsa-lib-1.0.9rc4-1, it probably was
because of a dmix bug (which caused other applications like rhythmbox and
beep-media-player to also hang) which recently got fixed.

Comment 3 Miloslav Trmač 2005-06-04 15:25:22 UTC
Works for me with a recent pre-FC4 snapshot too.


Note You need to log in before you can comment on or make changes to this bug.