Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157666 - yum crashes while trying other mirrors
Summary: yum crashes while trying other mirrors
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 163477 165234 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 16:14 UTC by Justin Graham
Modified: 2014-01-21 22:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 19:26:50 UTC


Attachments (Terms of Use)

Description Justin Graham 2005-05-13 16:14:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
RPM installer/updater
yum-2.3.2-2
On FC4 test 3 yum crashes when going thru the list of mirrors looking for an alternate site to download from.  It looks like an error in /usr/lib/python2.4/site-packages/urlgrabber/mirror.py.
It says "IndexError: list index out of range" and then stops.  I have not changed yums config file.

Version-Release number of selected component (if applicable):
yum-2.3.2-2

How reproducible:
Sometimes

Steps to Reproduce:
1.Simply run yum update.  it occurs when a file tries to find another mirror.
2.
3.
  

Actual Results:  yum runs a trace back to mirror.py, and crashes with a "IndexError: list index out of range" error

Additional info:

it does not appear to effect the performance of the system so it not severe, but highly annoying.

Comment 1 Rahul Sundaram 2005-08-27 20:00:45 UTC
*** Bug 163477 has been marked as a duplicate of this bug. ***

Comment 2 Rahul Sundaram 2005-08-27 20:01:56 UTC
*** Bug 165234 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2005-09-21 19:26:50 UTC
This should be fixed with current yum


Note You need to log in before you can comment on or make changes to this bug.