Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157635 - installation hangs on NIC detection (ALi M1689)
Summary: installation hangs on NIC detection (ALi M1689)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 10:49 UTC by cervajs
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-25 13:15:07 UTC


Attachments (Terms of Use)
tulip-bug.patch (deleted)
2005-05-18 17:01 UTC, John W. Linville
no flags Details | Diff

Description cervajs 2005-05-13 10:49:09 UTC
Description of problem:
installation fc4test3 hangs on 
kernel panic - not syncing: drivers/net/tulip/media.c:202
spin_unlock(drivers/net/tulip/tulip_core.c:ffff81003e955100) not locked. (not
tainted)


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. boot fc4test3 on motherboard with ALi M1689 chipset
2.
3.
  
Actual results:
system hang

Expected results:
installation detect NIC a continue

Additional info:
this is ALi M1689 chipset
k8combo-z board (www.asrock.com)
vendor notified too

Comment 1 John W. Linville 2005-05-18 17:01:31 UTC
Created attachment 114522 [details]
tulip-bug.patch

I definitely see the problem, this is my guess at the correct solution...

Comment 2 John W. Linville 2005-05-18 17:05:00 UTC
I have test kernels w/ the above patch here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Would you mind trying those kernels and posting the results here?  Thanks! 

Comment 3 cervajs 2005-05-25 09:38:14 UTC
sorry, but i cannot install fc4test3 due to unsupported sata controller :( (and
test the driver for NIC)
maybe i should fill another bug report

Comment 4 John W. Linville 2005-05-25 13:15:07 UTC
The patch has been picked-up in the official FC4 kernels...you should be OK w/ 
the next fc4test release.  I'm going to close this for now...please reopen if 
the problem persists past fc4test4.  Thanks! 


Note You need to log in before you can comment on or make changes to this bug.