Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157634 - Ehtereal will not update - failed deps
Summary: Ehtereal will not update - failed deps
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ethereal
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 10:37 UTC by Joe Reid
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-13 11:23:33 UTC


Attachments (Terms of Use)

Description Joe Reid 2005-05-13 10:37:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050509 Fedora/1.0.3-5 Firefox/1.0.3

Description of problem:
Possible relation to 157308 - compile issue with gcc3.4?

I cannot update etheral (or ethereal-gnome) to the latest versions due to missing deps:

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ethereal.i386 0:0.10.11-1.FC3.1 set to be updated
--> Running transaction check
--> Processing Dependency: librpmio-4.3.so for package: ethereal
--> Processing Dependency: librpm-4.3.so for package: ethereal
--> Processing Dependency: librpmdb-4.3.so for package: ethereal
--> Finished Dependency Resolution
Error: Missing Dependency: librpmio-4.3.so is needed by package ethereal
Error: Missing Dependency: librpm-4.3.so is needed by package ethereal
Error: Missing Dependency: librpmdb-4.3.so is needed by package ethereal

Looks like it may beed to be re-built against librpms?
rpm-libs.i386                            4.4.1-18.1             development
Matched from:
/usr/lib/librpmbuild-4.4.so
/usr/lib/librpmio-4.4.so
/usr/lib/librpm-4.4.so
/usr/lib/librpmdb-4.4.so
librpmbuild-4.4.so
librpmio-4.4.so
librpmdb-4.4.so
librpm-4.4.so


Version-Release number of selected component (if applicable):
ethereal.i386 0:0.10.11-1.FC3.1

How reproducible:
Always

Steps to Reproduce:
1. yum update ethereal
2.
3.
  

Actual Results:  Failed dependencies

Expected Results:  Successful update of ethereal

Additional info:

Comment 1 Radek Vokal 2005-05-13 11:23:33 UTC
The ethereal update is build against rpm-4.3.2-21 so you propably have newer rpm
from devel branch - than try also ethereal from devel and don't use the one from
FC3!


Note You need to log in before you can comment on or make changes to this bug.