Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157619 - GBK pinyin and Shuang Pin input style crash iiimd
Summary: GBK pinyin and Shuang Pin input style crash iiimd
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: IIIMF FC5Blocker FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-05-13 07:20 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
2 users (show)

Fixed In Version: iiimf-le-chinput-0.3-20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 23:30:18 UTC


Attachments (Terms of Use)
gdb message from /var/log/iiim (deleted)
2005-05-13 07:25 UTC, Lawrence Lim
no flags Details
gdb from shuang pin input style crashing iiimd (deleted)
2005-05-16 02:04 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2005-05-13 07:20:48 UTC
Description of problem:
When user switches from the default intelligent input style to GBK pinyin input
style. One keypress will crash iiimd.

Version-Release number of selected component (if applicable):
iiimf-le-chinput-0.3-19
iiimf-12.2-3

How reproducible:
Always

Steps to Reproduce:
1.LANG=zh_CN.UTF-8 gedit
2.ctrl-space to activate LE
3.select GBK pinyin input style
4.press 'a'  

Actual results:
crash

Expected results:
able to input normally


Additional info:

Bound imlexec:(9cc4460 -> 9cbadf8)
current ime = TL_hzinput.so
 ZNPY \u667a\u80fd\u62fc\u97f3
 PY GBK\u62fc\u97f3
 SHP \u53cc\u62fc
 CODE \u5185\u7801
Bound imlexec:(9cc4460 -> 9cbadf8)
Bound imlexec:(9c41908 -> 9c2bb10)
AUX is not started.
status has not been enabled yet. (1, 1)
Bound imlexec:(9c41908 -> 9c2bb10)
Bound imlexec:(9cc4460 -> 9cbadf8)
 ZNPY \u667a\u80fd\u62fc\u97f3
 PY GBK\u62fc\u97f3
 SHP \u53cc\u62fc
 CODE \u5185\u7801
Bound imlexec:(9cc4460 -> 9cbadf8)
IM_trans, kcode = 97(0x61)  kchar = a(0x61) modifier = 0 pres_buf = .
iiimd: xl_sysphrase.c:218: TL_GetPhrase: Assertion `nPhrase < p->TotalPhrase'
failed.
Variable "ptr" is not available.
Variable "pid" is not available.
Variable "fd" is not available.
Crash has occurred.  Please see /var/log/iiim/ or $HOME/.iiim/logs/ for details.

Comment 1 Lawrence Lim 2005-05-13 07:25:22 UTC
Created attachment 114324 [details]
gdb message from /var/log/iiim

Comment 2 Akira TAGOH 2005-05-13 12:26:57 UTC
It looks like iiimd got received invalid stuff from LE, then aborted.

Comment 3 Lawrence Lim 2005-05-16 02:03:01 UTC
Same problem with shuang pin as well.
Please let me know if you require a new bug for each input style.

----
Bound imlexec:(a1515a8 -> a13edb8)
 ZNPY æºè½æ¼é³
 PY GBKæ¼é³
 SHP åæ¼
 CODE åç 
Toggle client conversion mode to true.
status has not been enabled yet. (1, 1)
Bound imlexec:(a1515a8 -> a13edb8)
Bound imlexec:(a1515a8 -> a13edb8)
 ZNPY æºè½æ¼é³
 PY GBKæ¼é³
 SHP åæ¼
 CODE åç 
Bound imlexec:(a1515a8 -> a13edb8)
current ime = TL_hzinput.so
 ZNPY æºè½æ¼é³
 PY GBKæ¼é³
 SHP åæ¼
 CODE åç 
Bound imlexec:(a1515a8 -> a13edb8)
IM_trans, kcode = 97(0x61)  kchar = a(0x61) modifier = 0 pres_buf = .
iiimd: xl_sysphrase.c:218: TL_GetPhrase: Assertion `nPhrase < p->TotalPhrase'
failed.
Variable "ptr" is not available.
Variable "pid" is not available.
Variable "fd" is not available.
Crash has occurred.  Please see /var/log/iiim/ or $HOME/.iiim/logs/ for details.

Comment 4 Lawrence Lim 2005-05-16 02:04:24 UTC
Created attachment 114402 [details]
gdb from shuang pin input style crashing iiimd

Comment 6 Yu Shao 2005-05-31 15:50:34 UTC
Patched and rebuilt into fc4-HEAD with version 0.3-20.

Comment 7 Lawrence Lim 2005-05-31 23:30:18 UTC
Confirmed fixed in iiimf-le-chinput-0.3-20. It is crucial for this package to be
included in the upcoming FC4 Update.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.