Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157618 - hald requires restarting to detect new USB device
Summary: hald requires restarting to detect new USB device
Keywords:
Status: CLOSED DUPLICATE of bug 156167
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 07:12 UTC by Paul F. Johnson
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-13 09:51:54 UTC


Attachments (Terms of Use)

Description Paul F. Johnson 2005-05-13 07:12:10 UTC
Description of problem:
If you insert a USB pen, it is picked up. Dismount and try to mount a new device
and hald needs restarting before it is picked up

Version-Release number of selected component (if applicable):
hald-0.5.1-1
kernel-2.6.11-1.1288_FC4
hotplug-2004_09_23-5

How reproducible:
Always

Steps to Reproduce:
1. Plug in a USB pen, mount and dismount
2. Insert a new USB device into the same USB port
3.
  
Actual results:
The new USB device is not picked up

Expected results:
The new USB device is picked up

Additional info:
If I execute /etc/init.d/haldaemon restart, it reports that stopping hald has
failed, but the restart worked.

Restarting hald does not fix the continued problem with internal USB card readers.

Comment 1 David Zeuthen 2005-05-13 09:51:54 UTC

*** This bug has been marked as a duplicate of 156167 ***


Note You need to log in before you can comment on or make changes to this bug.