Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157603 - Install GRUB in Bootpartition fails, ever MBR used
Summary: Install GRUB in Bootpartition fails, ever MBR used
Keywords:
Status: CLOSED DUPLICATE of bug 151204
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 03:21 UTC by Helmut Blatter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-13 05:28:55 UTC


Attachments (Terms of Use)

Description Helmut Blatter 2005-05-13 03:21:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I've a PC with Windows XP and 3 Linux-Distributions. I'm using Bootmagic in MBR. I want to locate FC4 in hda9 with GRUB in Bootpartition. FC4-DVD ever installs GRUB to MBR.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. I manualy set FC4 (root) to hda9 with formating ext3
2. With extended Bootparameters it is possible to klick GRUB to hda9
3. Completition of installation with standards of germany
  

Actual Results:  FC4-GRUB is in MBR

Expected Results:  My Windows-Bootmanager Bootmagic should be in MBR and FC4-GRUB in hda9

Additional info:

After completition of installation I made a reconstruction of Bootmagic and started FC4-DVD again. Now I wanted to repair my FC4-Installation and klicked new Bootloader. I klicked to install GRUB in Bootpartition but afterwards I've got the message nothing done, because there are no changes. This is remarkable, because there is no Bootloader in hda9 and Bootmagic in MBR.

Comment 1 Marius Andreiana 2005-05-13 05:28:55 UTC
This is fixed in rawhide. Would be great if you could test the fix by installing
again from rawhide (http/ftp install) with boot.iso from rawhide.

*** This bug has been marked as a duplicate of 151204 ***


Note You need to log in before you can comment on or make changes to this bug.