Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157585 - logfactor5 segfaults
Summary: logfactor5 segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 21:15 UTC by petrosyan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 14:13:27 UTC


Attachments (Terms of Use)
Testcase for the chainsaw crasher (deleted)
2005-05-23 16:41 UTC, Gary Benson
no flags Details

Description petrosyan 2005-05-12 21:15:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050509 Fedora/1.0.3-5 Firefox/1.0.3

Description of problem:
both chainsaw and logfactor5 crash:

$ chainsaw
/usr/bin/build-classpath: error: could not find jaxp_parser_impl Java extension for this JVM
/usr/bin/build-classpath: error: All specified jars were not found
[main] DEBUG org.apache.log4j.chainsaw.MyTableModel - Total time [ms]: 1 in update, size: 0
Exception in thread "main" java.lang.ExceptionInInitializerError
   at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
   at org.apache.log4j.chainsaw.Main.Main() (Unknown Source)
   at org.apache.log4j.chainsaw.Main.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
Caused by: java.lang.IllegalArgumentException: Invalid letter iencountered at character 3.
   at java.text.SimpleDateFormat.compileFormat(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at java.text.SimpleDateFormat.applyPattern(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at java.text.MessageFormat$MessageFormatElement.setLocale(java.util.Locale) (/usr/lib/libgcj.so.6.0.0)
   at java.text.MessageFormat.scanFormat(java.lang.String, int, java.lang.StringBuffer, java.util.Vector, java.util.Locale) (/usr/lib/libgcj.so.6.0.0)
   at java.text.MessageFormat.applyPattern(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at java.text.MessageFormat.MessageFormat(java.lang.String, java.util.Locale) (/usr/lib/libgcj.so.6.0.0)
   at java.text.MessageFormat.MessageFormat(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at org.apache.log4j.chainsaw.DetailPanel.<clinit>() (Unknown Source)
   at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
   ...4 more

$ logfactor5
/usr/bin/build-classpath: error: could not find jaxp_parser_impl Java extension for this JVM
/usr/bin/build-classpath: error: All specified jars were not found
/usr/share/java-utils/java-functions: line 117:  4076 Segmentation fault      $JAVACMD $FLAGS -classpath $CLASSPATH $OPTIONS $MAIN_CLASS "$@"


Version-Release number of selected component (if applicable):
log4j-1.2.8-7jpp_3fc

How reproducible:
Always

Steps to Reproduce:
1. run chainsaw and logfactor5 from the terminal


Additional info:

I have the latest up2date FC development version

Comment 1 petrosyan 2005-05-13 00:15:52 UTC
jaxp_parser_impl is provided by xerces-j2 package, however log4j does not depend
on it.
so this dependency should be fixed properly.

Comment 2 Fernando Nasser 2005-05-13 13:32:59 UTC
Gary is handling the Fedora version of this package.

Comment 3 Gary Benson 2005-05-23 16:13:46 UTC
Sorry for the delay -- I've been on vacation.  Looking now...

Comment 4 Gary Benson 2005-05-23 16:41:59 UTC
Created attachment 114723 [details]
Testcase for the chainsaw crasher

Comment 5 Gary Benson 2005-05-23 16:54:00 UTC
Hmmm, so the default style for times in MessageFormats _is_ medium, but actually
specifying it as such causes this error...

Comment 6 Gary Benson 2005-05-23 17:29:31 UTC
I've worked around the chainsaw thing in log4j-1.2.8-7jpp_4fc; the lf5 one will
have to wait a while I'm afraid...

Comment 7 Gary Benson 2005-05-24 10:05:40 UTC
The chainsaw one is http://gcc.gnu.org/bugzilla/show_bug.cgi?id=21736

Comment 8 petrosyan 2005-05-25 12:57:04 UTC
chainsaw from log4j-1.2.8-7jpp_4fc does not crash anymore, but still gives the
following error message:
$ chainsaw
/usr/bin/build-classpath: error: could not find jaxp_parser_impl Java extension
for this JVM
/usr/bin/build-classpath: error: All specified jars were not found


Comment 9 Gary Benson 2005-05-25 13:21:43 UTC
I've filed that particular issue as bug 158751; Cc yourself on that if you want
to keep track of it.

Comment 10 petrosyan 2005-06-02 14:55:29 UTC
logfactor5 still segfaults with the following error message:
$ logfactor5
/usr/share/java-utils/java-functions: line 117:  2974 Segmentation fault     
$JAVACMD $FLAGS -classpath $CLASSPATH $OPTIONS $MAIN_CLASS "$@"

Comment 11 Gary Benson 2005-06-02 15:27:27 UTC
I haven't looked at this yet.  How big a problem is it for you?

Comment 12 Gary Benson 2005-06-23 14:13:27 UTC
The logfactor5 issue is being tracked on as bug 161126.


Note You need to log in before you can comment on or make changes to this bug.