Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157579 - `dialog --calendar "select a date" 4 40|more` messes up gnome terminal
Summary: `dialog --calendar "select a date" 4 40|more` messes up gnome terminal
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 19:56 UTC by Neo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-14 04:41:15 UTC


Attachments (Terms of Use)

Description Neo 2005-05-12 19:56:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The following command messes up gnome terminal:
dialog --calendar "select a date" 4 40|more

The screen displays very strange characters after the above command completes. If it does not mess up the display, then ENTER key does not work (not totally, it does not do \r\n and I can still run commands).

Version-Release number of selected component (if applicable):
gnome-terminal-2.10.0-2

How reproducible:
Sometimes

Steps to Reproduce:
1. Start a gnome terminal.
2. Run `dialog --calendar "select a date" 4 40|more`.
3. Hit ENTER.
4. Try other normal commands (e.g., ls).

Actual Results:  Most probably, the screen is messed up (filled by strange characters). And ENTER key does not function as it should; pressing ENTER does not produce \r\n sequence any more.

Expected Results:  None of the above.

Additional info:

I tested it with xterm, it seems xterm is less buggy, since only ENTNER key loses effect.

Comment 1 Ray Strode [halfline] 2005-05-13 14:56:20 UTC
Hi,

This looks like it's actually a bug in vte, the rendering widget used by
gnome-terminal.  I'm going to reassign the bug to that component.

Comment 2 Warren Togami 2005-05-14 04:41:15 UTC
This test looks equally messed up on FC4 gnome-terminal, konsole and xterm to
me.  If you want it fixed in gnome-terminal please report it upstream to GNOME
Bugzilla against the vte component.  This is not something that we have time to
fix ourselves.


Note You need to log in before you can comment on or make changes to this bug.