Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157563 - Anaconda quietly saves the FTP password
Summary: Anaconda quietly saves the FTP password
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 18:53 UTC by yuubyou+rhbz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-17 19:23:49 UTC


Attachments (Terms of Use)

Description yuubyou+rhbz 2005-05-12 18:53:29 UTC
Description of problem:

When installing via FTP to a real account, Anaconda masks the password, leading
the user to believe it will use reasonable care with the password. However, it
silently saves the password to /root/anaconda-ks.cfg on the installed system. 
This can easily lead to unintended disclosure of the password.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Select FTP install,`non-anonymous FTP'.
2. Proceed with install.
3. Inspect /root/anaconda-ks.cfg
  
Actual results:
Plaintext password in the ks file.

Expected results:
At least a warning on the password-entry form that the password will go into the
file.  Better would be an option to prevent saving the password.

Additional info:

Comment 1 Chris Lumens 2006-01-17 19:23:49 UTC
The anaconda-ks.cfg file is safely stored in root's home directory which has
0700 permissions, while the file itself is given 0600 permissions.  Note that
other passwords are stored in the anaconda-ks.cfg file too.


Note You need to log in before you can comment on or make changes to this bug.