Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157531 - cannot install from images on lvm volume
Summary: cannot install from images on lvm volume
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
: 182975 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 12:37 UTC by Avi Kivity
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-14 20:14:30 UTC


Attachments (Terms of Use)

Description Avi Kivity 2005-05-12 12:37:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
anaconda has a nice feature where one can place the iso images on the hard 
drive. this does not work for lvm volumes, which is unfortunate since fedora 
installs lvm by default. 

Version-Release number of selected component (if applicable):
anaconda-10.2.0.61-1

How reproducible:
Always

Steps to Reproduce:
1. download images to some directory on an lvm volume 
2. boot using the installer kernel and init rd, with askmethod. 
3. select hard drive. 
4. look in vain for the logical volume where the images are installed. 
   

Actual Results:  it's not there  

Expected Results:  the volume is there 

Additional info:

Comment 1 Chris Lumens 2007-03-14 20:14:30 UTC
We can't support these advanced storage methods (LVM, RAID, ...) without
extensive changes to the loader.

Comment 2 Chris Lumens 2007-03-14 21:36:44 UTC
*** Bug 182975 has been marked as a duplicate of this bug. ***

Comment 3 Eric Brunson 2007-03-14 22:51:42 UTC
I would admit that supporting RAID and other advanced storage methods may be out
of scope, but LVM is the default volume manager for Fedora.  The default layout
allocates a small ext partition and eats all the rest of your disk with LVM, so
there is not acceptable place to put ISOs or anaconda.  Either support LVM or
don't, don't do it half assed.

Comment 4 Eric Brunson 2007-03-14 22:53:00 UTC
That should read 'no acceptable place to put ISOs for anaconda'.


Note You need to log in before you can comment on or make changes to this bug.