Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157524 - [x86_64] 32bit apps using gtk file dialog are missing floppy icon
Summary: [x86_64] 32bit apps using gtk file dialog are missing floppy icon
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 10:23 UTC by Tim Waugh
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-01 15:39:13 UTC


Attachments (Terms of Use)

Description Tim Waugh 2005-05-12 10:23:54 UTC
Description of problem:
The only way to open a document from a floppy disk seems to be to navigate to
the floppy using nautilus first and right-click on it.  File->Open from
OpenOffice.org only shows a dialog with:

  Home
  Desktop
  Filesystem

Yes, yes, I could go to /media/floppy -- if it had already been mounted.  But
I'm sure that in Fedora Core 3 it showed Floppy there too, and when
double-clicked it mounted it as you would expect.

Indeed, gedit's File->Open has this expected behaviour.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.100-1

How reproducible:
100%

Steps to Reproduce:
1. File->Open
  
Actual results:
 Home
 Desktop
 Filesystem

Expected results:
 Home
 Desktop
 Filesystem
 Floppy Drive
 CD-ROM Drive
 CD-RW Drive

Additional info:

Comment 1 Caolan McNamara 2005-05-31 12:19:44 UTC
There should be nothing special about the OOo file dialog, it's just the same
gnome one as gedit. Both run as the same logged in user ?

Comment 2 Tim Waugh 2005-05-31 13:08:22 UTC
Yes, both as same user.  I'm running them at the same time at the moment, and
the gedit dialog has four things that the OOo one does not: Floppy Drive, CD-ROM
Drive, CD-RW Drive, and 'backup' (a mounted external storage device).

Perhaps OOo is passing different flags.

Comment 3 Caolan McNamara 2005-06-16 15:31:40 UTC
hmm, 64bit eh ? how about on a 32bit machine, OOo is 32bit, is there another
32bit gnome-vfs and gtk file dialog using app to see if the problem is generic
for 32bit gtk on 64bit.

amusingly i have neither a 64bit machine or a floppy drive :-)

Comment 4 Tim Waugh 2005-06-16 15:39:58 UTC
Okay, yes, it works on a 32-bit machine -- hadn't spotted that!

I have a 32-bit mozilla installed on this x86_64 machine, and sure enough, "Open
File..." from the menu gives the same symptom of missing the removable media.

Comment 5 Caolan McNamara 2005-06-16 15:52:26 UTC
righteo, so a generic "32bit apps using gtk file dialog are missing floppy icon"
rather than a specific OOo problem.

Comment 6 Alexander Larsson 2006-09-01 15:20:01 UTC
Is this still a problem?

Comment 7 Tim Waugh 2006-09-01 15:39:13 UTC
No, seems to be fine on FC5 now.


Note You need to log in before you can comment on or make changes to this bug.