Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157523 - cman-kernel-xenU takes over 5 minutes to form a cluster
Summary: cman-kernel-xenU takes over 5 minutes to form a cluster
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cman-kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 09:55 UTC by Christine Caulfield
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 08:55:51 UTC


Attachments (Terms of Use)

Description Christine Caulfield 2005-05-12 09:55:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050509 Fedora/1.0.3-5 Firefox/1.0.3

Description of problem:
Running cman under xen, all the timeouts are 10 times too long. For instance, it takes around 5.5 minutes for a single node to form a new cluster, rather than 30 seconds.


Version-Release number of selected component (if applicable):
cman-kernel-xenU-2.6.11.3-20050425.154843.FC4.14

How reproducible:
Always

Steps to Reproduce:
1. Run Fedora in a Xen VM
2. Install cman
3. cman_tool join
4. wait......
  

Actual Results:  May 11 10:58:23 fedora1 kernel: CMAN: Waiting to join or form a Linux-cluster
May 11 11:03:43 fedora1 kernel: CMAN: forming a new cluster


Expected Results:  May 11 11:48:41 arthur kernel: CMAN: Waiting to join or form a Linux-cluster
May 11 11:49:13 arthur kernel: CMAN: forming a new cluster


Additional info:

IME, this is caused by building the modules outside of the kernel tree and not adding ARCH=xen to the build command line. This causes HZ to be the (normal i386) default value of 1000, rather than the xen value of 100.

As HZ is the number of time ticks in a second, and it's used by CMAN (and the DLM) to calculate timeouts, it seems reasonable to me that this is the probably cause of the timeouts being 10x out!

Comment 1 Christine Caulfield 2005-05-12 09:55:46 UTC
Reassign to Chris as it's a build problem.

Comment 2 Chris Feist 2005-05-17 18:25:12 UTC
This should be fixed in the latest fc4 builds
(cman-kernel-2.6.11.3-20050425.154843.FC4.19) and up.

Let me know if it's not fixed.

Comment 3 Christine Caulfield 2005-05-18 08:16:07 UTC
'Fraid not:

May 18 03:47:00 fedora1 kernel: CMAN 2.6.11.3-20050425.154843.FC4.19 (built May 
17 2005 11:33:22) installed
May 18 03:47:00 fedora1 kernel: NET: Registered protocol family 30
May 18 03:47:43 fedora1 kernel: CMAN: Waiting to join or form a Linux-cluster
May 18 03:53:03 fedora1 kernel: CMAN: forming a new cluster


Comment 4 Chris Feist 2005-05-18 21:34:26 UTC
I also added ARCH=xen in the make install and that appears to have done.

Let me know if it still isn't fixed.

(should be fixed in CMAN 2.6.11.4-20050517.141233.FC4.3 and beyond).

Comment 5 Christine Caulfield 2005-05-19 08:55:51 UTC
That works. thanks


Note You need to log in before you can comment on or make changes to this bug.