Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157520 - make dep breaks build
Summary: make dep breaks build
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ernie Petrides
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 08:52 UTC by Colin Leroy
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-03 23:59:42 UTC


Attachments (Terms of Use)
Rules.make patch to fix that. (deleted)
2005-05-12 08:52 UTC, Colin Leroy
no flags Details | Diff

Description Colin Leroy 2005-05-12 08:52:27 UTC
Description of problem:
If you issue a `make dep` after make config (or oldconfig), the
include/linux/modversions.h file is incorrectly regenerated. It misses the
rhconfig.h include.

Version-Release number of selected component (if applicable):
# cat /etc/redhat-release
Red Hat Enterprise Linux ES release 3 (Taroon)
# rpm -q kernel-source
kernel-source-2.4.21-15.0.3.EL
kernel-source-2.4.21-27.0.2.EL


How reproducible:
Always

Steps to Reproduce:
1.make oldconfig
2.make dep
3.make bzImage
  
Actual results:
Various strange build errors.

Expected results:
A shiny new kernel...

Additional info:

Comment 1 Colin Leroy 2005-05-12 08:52:27 UTC
Created attachment 114285 [details]
Rules.make patch to fix that.

Comment 3 Colin Leroy 2005-05-23 15:18:21 UTC
Hi,

nothing new about this?

Comment 4 Ernie Petrides 2005-05-23 20:06:00 UTC
Not yet.  Obviously, "make dep" works fine in our internal build
environment.  I just need to track down what's different.

Comment 5 Colin Leroy 2005-05-23 20:12:35 UTC
Ok; don't hesitate on bugging me for more information!
Thanks.

Comment 6 Ernie Petrides 2005-06-03 23:59:42 UTC
Hi, Colin.

The correct build-from-source procedure is as follows:

  1) make mrproper
  2) cp configs/kernel-2.4.21-i686-smp.config .config  [or some other config]
  3) make oldconfig
  4) make dep
  5) make bzImage
  6) make modules

The Rules.make patch that you proposed in comment #1 does not work in our
build environment because include/linux/rhconfig.h does not exist.  Rather,
it is fabricated by the kernel spec file during kernel-source-* RPM builds.

Once you run "make dep", many things specific to the kernel-source-* RPM
(e.g., the funky include/linux/modules/*.ver files) are overwritten, and
thus you are forced to use the full build (from scratch) procedure above.

Cheers.  -ernie



Note You need to log in before you can comment on or make changes to this bug.