Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157518 - can't run postinstall procedure
Summary: can't run postinstall procedure
Keywords:
Status: CLOSED DUPLICATE of bug 157970
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-12 08:22 UTC by Andrew Power
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 01:32:28 UTC


Attachments (Terms of Use)

Description Andrew Power 2005-05-12 08:22:40 UTC
Description of problem:
can't run postinstall procedure


How reproducible:

Steps to Reproduce:
1. start text install on x86_64 (disabled selinux, disabled firewall, selection
server)
2. after all packages downloaded, and installed got error message about post install
  

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 496, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 172, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 240, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 1199, in doPostInstall
    stdout = devnull)
  File "/usr/lib/anaconda/iutil.py", line 53, in execWithRedirect
    raise RunTimeError, command + " can not be run"
RuntimeError: /usr/bin/kudzu can not be run"

Comment 1 Dan Carpenter 2005-05-12 23:27:44 UTC
In the post install anaconda does a chroot and tries to run 
/usr/bin/kudzu under the newly installed system.

There was a bug in FC2 x86_64 where the if there was a + in in the `fdisk -l`*
output something didn't get parsed correctly and none of the packages installed.
 This would cause chrooting and running /usr/sbin/kudzu to fail (Since nothing
was installed).

I think this was fixed in FC3.

This sounds similar.

*This '+' mark in fdisk -l indicates rounding.

Comment 2 Andrew Power 2005-05-13 07:03:08 UTC
FC3 x86_64 is working correctly.
This is FC4 test.

---

~ # fdisk -l

Disk /dev/sda: 80.0GB, 80060424192 bytes
255 heads, 63 sectors/track, 9733 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9603    77136066   83  Linux
/dev/sda2            9604        9733     1044225   82  Linux swap / Solaris

---

when install failed, switch to busybox, and try this:

~ # chroot /mnt/sysimage
sh-3.00# /usr/sbin/kudzu
sh: /usr/sbin/kudzu: No such file or directory


Where is kudzu?????

Comment 3 Jeremy Katz 2005-05-16 20:32:50 UTC
Can you provide the complete anacdump.txt you received?

Comment 4 Andrew Power 2005-05-17 13:28:34 UTC
this problem only affect when you're not select any things...
since today i was select only minimal (cca 430Mb) install
when i accept default selection, this problem is not reproducible

Comment 5 Jeremy Katz 2005-05-19 01:32:28 UTC

*** This bug has been marked as a duplicate of 157970 ***


Note You need to log in before you can comment on or make changes to this bug.