Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157471 - xconsole "Can't open console"
Summary: xconsole "Can't open console"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 21:02 UTC by Nigel Horne
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-27 16:39:27 UTC


Attachments (Terms of Use)

Description Nigel Horne 2005-05-11 21:02:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
xconsole always says "Couldn't open console" even if you start it as root!

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.13

How reproducible:
Always

Steps to Reproduce:
1.  xconsole&
2.
3.
  

Actual Results:  Couldn't open console

Expected Results:  See "man xconsole" for expected results

Additional info:

Comment 2 Mike A. Harris 2005-05-16 17:57:26 UTC
Reassigning to correct component "xorg-x11".  XFree86 is not part of
Fedora Core anymore since FC2.

Comment 3 Richard Harman 2005-06-16 17:23:27 UTC
(In reply to comment #2)
> Reassigning to correct component "xorg-x11".  XFree86 is not part of
> Fedora Core anymore since FC2.

I have the same problem, in RHEL4 -- the console messages show up on the virtual
console, *under* the running X server.  If you cat /dev/vcs7, or kill X, you can
see the console messages.

Comment 4 Rahul Sundaram 2005-06-30 13:01:24 UTC
(in replay to 

"I have the same problem, in RHEL4 -- the console messages show up on the virtual
console, *under* the running X server.  If you cat /dev/vcs7, or kill X, you can
see the console messages."(In reply to comment #3)

For RHEL4 I would suggest working through support
(https://www.redhat.com/apps/support/) to get the problem resolved.

Comment 5 Goswin 2005-07-13 10:49:24 UTC
If I do an strace xconsole on RHEL 4 I see that I tries to open one of the 
vertual terminals /dev/ptyp<N>, If I do the same on RHEL 3 I see that it 
opens /dev/console, /dev/ptyp0 and /dev/ttyp0. The last to devices don't exist 
on RHEL 4.


Comment 7 Mike A. Harris 2006-01-17 09:00:06 UTC
Fedora Core 3 has been transferred to the Fedora Legacy project currently,
however UNIX 98 pty support has been backported from Xorg CVS for a future
RHEL4 update.  The same patch is being considered also for possible
inclusion in a future Fedora Core 4 update.  While we no longer provide
updates for FC3, the same patch could be utilized by the Fedora Legacy
project for future X updates as well.

The issue is also resolved in the latest xorg-x11 which is currently in
rawhide (X11R7).

I'm changing the product version to Fedora Core 4 for this issue, to track
it for future consideration for FC4.



Note You need to log in before you can comment on or make changes to this bug.