Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157445 - --server option should allow settings per network interface/test.
Summary: --server option should allow settings per network interface/test.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Rob Landry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 18:19 UTC by Rob Landry
Modified: 2018-10-20 01:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-29 16:45:41 UTC


Attachments (Terms of Use)
hardwaretest.py patch adding per-test server setting (deleted)
2008-10-08 18:49 UTC, Greg Nichols
no flags Details | Diff
certificationtest.py patch to add per-test server setting to xml storage (deleted)
2008-10-08 18:50 UTC, Greg Nichols
no flags Details | Diff
xml DTD changes for added server attribute (deleted)
2008-10-08 18:51 UTC, Greg Nichols
no flags Details | Diff

Description Rob Landry 2005-05-11 18:19:06 UTC
$summary, allows mixing network types (eg. fibre and copper where no
fibre<->copper interconect exsits.

Comment 2 Greg Nichols 2008-07-02 02:17:41 UTC
A work-around exists currently by running each test individually and resetting
the --server option each time:

> hts certify --test network --device eth0 --server server1
> hts certify --test network --device eth1 --server server2

The fix would be to allow the syntax for test planning:

> hts plan --test network --device eth0 --server server1
> hts plan --test network --device eth1 --server server2

So that the --server option could be left off the "hts certify" runs.

Comment 3 Greg Nichols 2008-08-22 01:51:05 UTC
*** Bug 437874 has been marked as a duplicate of this bug. ***

Comment 4 Greg Nichols 2008-10-08 18:49:42 UTC
Created attachment 319778 [details]
hardwaretest.py patch adding per-test server setting

This patch allows the hts server to be set for individual tests, via the syntax:

hts plan --test <testname> ( --device <device name> | --udi <udi> ) --server <server name or IP address>

If a server is set for a test, it overrides the default setting via the plan or 
certify command.

Comment 5 Greg Nichols 2008-10-08 18:50:46 UTC
Created attachment 319779 [details]
certificationtest.py patch to add per-test server setting to xml storage

Comment 6 Greg Nichols 2008-10-08 18:51:50 UTC
Created attachment 319780 [details]
xml DTD changes for added server attribute

Comment 8 Yan Tian 2008-12-30 11:20:11 UTC
Verified --server can be set for individual tests with hts-5.3-12.


Note You need to log in before you can comment on or make changes to this bug.