Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157438 - ecj bootstrap sets compile properties and then ignores them
Summary: ecj bootstrap sets compile properties and then ignores them
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 17:44 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 17:55:12 UTC


Attachments (Terms of Use)

Description Robin Green 2005-05-11 17:44:17 UTC
Description of problem:
The ant files for ecj bootstrap in the eclipse source rpm set some compile
properties and then ignore them. Either the properties should be deleted if they
are unnecessary, or they should be used.

Version-Release number of selected component (if applicable):
eclipse-3.1.0_fc-0.M6.15

How reproducible:
Every time

Steps to Reproduce:
1. Try to change javacTarget in
/usr/src/redhat/BUILD/eclipse-3.1.0_fc/jdtcoresrc/compilejdtcore.xml before building
  
Actual results:
No effect

Expected results:
major.minor number of generated class files should be changed

Additional info:
Yes, I did check that the rpmbuild had not overwritten my change to
compilejdtcore.xml. The problem occurs because the compile properties are not
passed to the javac task.

Comment 1 Andrew Overholt 2005-05-11 17:55:12 UTC
This is an upstream bug.

Comment 2 Robin Green 2005-05-11 18:42:10 UTC
Whoops! Now filed as https://bugs.eclipse.org/bugs/show_bug.cgi?id=94813. Sorry
about that.


Note You need to log in before you can comment on or make changes to this bug.