Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157428 - Tried (and failed) to create Volume Group even after I changed my mind about using LVM
Summary: Tried (and failed) to create Volume Group even after I changed my mind about ...
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2005-05-11 15:44 UTC by Derek Poon
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-01-13 20:18:06 UTC

Attachments (Terms of Use)

Description Derek Poon 2005-05-11 15:44:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1. During install (not an upgrade), opt to manually partition using Disk Druid.
2. Make /dev/hda6 into an LVM Volume Group ("VolGroup00"), containing one virtual volume.  Mount that virtual volume as /, and create no other mount points.
3. Try to continue, but get error dialog saying that the boot partition must not be LVM.
4. OK, never mind, I'll eliminate all use of LVM.  Delete VolGroup00, change /dev/hda6 from an LVM Volume Group to a regular ext3 partition instead.
5. Continuing again, this time no error dialog.
6. When the installer actually performs the partitioning/formatting, it crashes.

Actual Results:  Installer tries to set up LVM anyway, and crashes.
Grumble, reboot, start install all over again, this time without touching LVM.

Expected Results:  Happy user running FC4 in an ext3 partition without LVM.

Additional info:

Python traceback:              handleRenderCallback
iw/   renderCallback               nextClicked          gotoNext          moveStep          turnOnFilesystems            createLogicalVolumes            setupDevice

SystemError: vgcreate failed for VolGroup00

Comment 1 Chris Lumens 2005-05-11 18:18:01 UTC
Can you please post the entire anaconda dump file?

Comment 2 Daniel Polanco 2005-07-04 09:22:32 UTC
Having a similar problem and not sure if I should post on a different thread but
here is what it is. My set up:
MSI K8N Platinum, AMD 3500+, 1GB RAM, Audigy ZS Gamer, Sony CD-RW Burner, a
120GB Seagate IDE (Master), and a 250GB Hitachi (Slave).
I'm a newb to Fedora so sorry if I'm just making a simple mistake but the
problem lies here. My 120GB is dedicated to MS XP and the new drive(250GB)was
partitioned with Partition Commander to have a 150GB fat32 partition. After
rebooted and started up with FC4, went through setup installing a Workstation
with some extra goodies. When Disk Druid came up, ran it auto through only the
250GB Hitachi so it would be as a fresh install but when I came to the final
screen before install it bugs out. I would hit the next button and it would
start to setup when this Exception rang out:


Traceback (most recent call last):
  File "/usr/lib/anaconda/", line 1137, in handleRendeCallback
  File "/usr/lib/anaconda/iw/", line 244, in renderCallback
  File "usr/lib/anaconda/", line 873, in nextClicked
  File"/usr/lib/anaconda/", line 174, in goNext
  File "/usr/lib/anaconda/" line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/", line 582, in turnOnFilesystems
  File "/usr/lib/anaconda/", line 1472, in createLogicalVolumes
  File "/usr/lib/anaconda/", line 2088, in setupDevice
    raise SystemError, "vgcreate failed for %s" %(,)
SystemError: vgcreate failed for VolGroup00

I am going to try and install it without the fat32 because I imagine that will
fix it easy, and as well... I imagine it says somewhere you aren't suppose to
put a fat32 partition with Linux and I just didn't see it. But yea, this problem
is consistent and runs through the same way every time.


Comment 3 Daniel Polanco 2005-07-04 09:37:31 UTC
Scratch that. Deleted fat32 partition and still came up with same problem. Going
to try one last thing... going to try and do manual install. If this doesn't
work, I'm done for now. I would think it would be a hardware issue but I had
already installed FC4 once and it didn't work because of other issues... but
System Commander is enabled so maybe there? Dunno... anyway here goes nothing.

Comment 4 Daniel Polanco 2005-07-04 10:04:58 UTC
Went a different route and the problem was bypassed. All throughout this
process, my P/S2 mouse was not being identified for whatever reason. So instead
of using GUI, went through text mode with auto Disk Droid for only the slave,
and seemingly it ran through. Only problem is now... that System Commander says
it doesn't have a operating system I think I'm going to be forced to instal
GRUB... But I really have no clue...


Comment 5 John Thacker 2007-01-13 20:18:06 UTC
(This is a mass update of bugs which have been in the NEEDINFO state unmodified
for over a year and have not been confirmed for a still supported version of
Fedora Core.)

Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.