Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157425 - Can not move subfolders to maildir "root" folder
Summary: Can not move subfolders to maildir "root" folder
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 15:25 UTC by Gianluca Sforna
Modified: 2018-04-11 15:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-18 23:44:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 303571 None None None Never

Description Gianluca Sforna 2005-05-11 15:25:01 UTC
Description of problem:
I am running a Dovecot IMAP server, with mailboxes in Maildir format.
With thunderbird I can create new folders and also drag and drop them into other
folders.
However, the move operation fails if destination is the root folder and not
another existent folder.

Version-Release number of selected component (if applicable):
thunderbird-1.0.2-1.3.2

How reproducible:
Always

Steps to Reproduce:
1. Create a folder "test1"
2. Create another folder "test2"
3. move test2 into test1: success
4. try to move back test2 to the top level

Actual results:
thunderbird complains:
The current command did not succeed. The mail server responded: Mailbox exists..

Expected results:
the test2 folder is put back at the top level

Additional info:
I suspected Dovecot was to blame for the problem, but then I tried the same
operation with Evolution and it worked as expected.
Moreover I used ethereal to capture the IMAP connection and it recorded the
following (wrong) command:
rename: "test2.test1" "test2.test1"
with the obvious response:
NO Mailbox exists.

Comment 1 Greg Trounson 2005-07-19 22:48:11 UTC
Confirmed presence of bug with the following:
  
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2
(on FC4),
Thunderbird 1.0.2-6 (20050513) (on FC4),
Thunderbird 1.0.2-1.3.3 (on FC3) 
Dovecot 0.99.14-1 (on debian server)

Comment 2 Gianluca Sforna 2006-01-02 23:53:39 UTC
Also filed at bugzilla.mozilla.org:

https://bugzilla.mozilla.org/show_bug.cgi?id=303571

Comment 3 Gianluca Sforna 2006-04-20 07:04:17 UTC
Upstream finally fixed the bug. Are there any chance we can have the patch in a
FC5 update, until there is a new release with the fix?

Comment 4 Matěj Cepl 2007-05-15 20:38:54 UTC
Reporter, could you please reproduce this bug with the latest package for your
distribution? I cannot reproduce this with FC6 (and there is a same version of
TB on FC5 as it is on FC6). Thanks.

Comment 5 Gianluca Sforna 2007-05-16 08:31:05 UTC
It is still there in my laptop with FC6 running thunderbird-1.5.0.10-1.fc6

Since upstream marked this bug with keyword "fixed1.8.1" I guess it should be
fixed in the 2.0 series, but I had no time to test this on F7.

If that is true and you want to fix it in the 1.5 series, I think the only
solution is to apply the patch they did on the Fedora SRPM

Comment 6 Matěj Cepl 2007-05-18 23:44:37 UTC
This bug has been already registered in the upstream database and we believe
that it is more approriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.



Note You need to log in before you can comment on or make changes to this bug.