Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157424 - U1 kernel 2.6.9-6.37.EL ptrace panics
Summary: U1 kernel 2.6.9-6.37.EL ptrace panics
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
: 157433 157831 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 15:23 UTC by Andrew Haley
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHEL 4 U2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-21 15:06:51 UTC


Attachments (Terms of Use)
kernel dump (deleted)
2005-05-11 15:25 UTC, Andrew Haley
no flags Details
Proposed fix. (deleted)
2005-05-11 15:44 UTC, David Woodhouse
no flags Details | Diff
Upstream fix. (deleted)
2005-05-12 13:24 UTC, David Woodhouse
no flags Details | Diff

Description Andrew Haley 2005-05-11 15:23:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
kernel panic in ptrace


Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. run gdb
2.
3.
  

Actual Results:  kernel panic

Additional info:

This happens a few times per week under heavy debug load.

Comment 1 Andrew Haley 2005-05-11 15:25:49 UTC
Created attachment 114247 [details]
kernel dump

Comment 2 David Woodhouse 2005-05-11 15:44:05 UTC
Created attachment 114248 [details]
Proposed fix.

Yeah, looks obvious. We don't do the lazy fpu saving on SMP machines, and we
object violently to being asked to save the FPU for a non-current task.

Comment 3 David Woodhouse 2005-05-11 15:49:19 UTC
Hm. Actually I'm unconvinced the above is anything more than a workaround. The
BUG() will only trigger if MSR_FP is enabled for the child, and that really
shouldn't be happening. 

Comment 4 Suzanne Hillman 2005-05-11 20:50:36 UTC
*** Bug 157433 has been marked as a duplicate of this bug. ***

Comment 5 Ernie Petrides 2005-05-11 21:58:05 UTC
*** Bug 157433 has been marked as a duplicate of this bug. ***

Comment 6 Ernie Petrides 2005-05-11 22:00:00 UTC
Fixing kernel version and assigning.

Comment 7 David Woodhouse 2005-05-12 13:24:21 UTC
Created attachment 114293 [details]
Upstream fix.

This is the real fix. The problem we weren't correctly waiting for the inferior
to be taken off its CPU. Its register set really was in some other CPU, not in
the place we were looking for it, and that's why the FPU was still marked as
enabled.

Comment 11 Dave Jones 2005-05-17 06:29:24 UTC
*** Bug 157831 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.