Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157420 - megaraid driver doesn't recognize logical RAID drives on install
Summary: megaraid driver doesn't recognize logical RAID drives on install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 15:05 UTC by Jason
Modified: 2015-01-04 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 13:52:08 UTC


Attachments (Terms of Use)

Description Jason 2005-05-11 15:05:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
I have been unable to install any FC4 test version on my HP LC2000 Netserver because the kernel does not have the megaraid driver builtin, it has the newer megaraid_mbox driver which does not work on the older raid cards.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  download a fc4 test iso
2.  burn to cd
3.  try to install on a hp lc2000 netserver, or any one of the older lsi raid cards.
  

Actual Results:  I was unable to install FC4.

Expected Results:  I should be able to install FC4, either the kernel needs the driver builtin or I should be able to select the megaraid driver from the list of drivers.

Additional info:

This is a duplicate of bug 138590 which has been open for over six months.  I wanted to open this bug so the people who are doing the FC4 stuff are aware that the problem still exists.  I have been updating 138590, but noone seems interested in fixing it.

Comment 1 Dave Jones 2005-05-17 06:36:14 UTC
both old, and new modules are built.

-rwxr--r--  1 root root  68144 May 13 14:24 megaraid.ko*

-rwxr--r--  1 root root 80832 May 13 14:24 megaraid_mbox.ko*
-rwxr--r--  1 root root 24608 May 13 14:24 megaraid_mm.ko*

You should be able to select the legacy module during the installation.
I'm puzzled. Jeremy ?


Comment 2 Jeremy Katz 2005-05-23 14:49:37 UTC
No one told me the old driver came back :-)  Added megaraid to the module list
that anaconda pulls in.  megaraid_mm is just the management side and so isn't
needed during install.

Comment 3 Dave Jones 2005-06-27 23:14:01 UTC
Mass update for bugs reported against -test:
Updating version field to FC4 final. Please retest with final FC4 release if you
have not already done so. Thanks.

Comment 4 Dave Jones 2005-06-27 23:23:58 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.

Comment 5 Jason 2005-06-28 13:52:08 UTC
FC4 final works great with the HP NetRaid 1Si raid card.

Thanks for fixing this.


Note You need to log in before you can comment on or make changes to this bug.