Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157413 - can not connect to smtp server
Summary: can not connect to smtp server
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-05-11 14:01 UTC by Thilo Pfennig
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-31 15:41:11 UTC


Attachments (Terms of Use)

Description Thilo Pfennig 2005-05-11 14:01:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
If you have set to always connect secure to a SMTP server, the connection will not  function.

Version-Release number of selected component (if applicable):
evolution-2.2.2-5

How reproducible:
Always

Steps to Reproduce:
1. set "always" in SMTP connect
2. try to send an email

  

Actual Results:  connect to server fails

Expected Results:  connect established.

Additional info:

if you choose always if possible there is no problem and I see a TLC connect in my logs. I like to set it rather to always, because then I see if TLS is not possible (sometimes smtp server get corrupted, too on an update and one does not get informed about not encrypted SMTP!)

Comment 1 Dave Malcolm 2005-05-12 02:14:11 UTC
"sometimes smtp server get corrupted, too on an update and one does not get
informed about not encrypted SMTP!"
Doesn't this mean there's a server problem?  It sounds like Evolution is
"sucessfully failing" in this case.



Comment 2 Thilo Pfennig 2005-05-12 10:22:17 UTC
No my server (exim4) says that there are TLS connections. An evolution update
rarely leads to a server failure.

Comment 3 Marius Andreiana 2005-05-13 05:22:39 UTC
I'm successfully using smtp.gmail.com, does it work for you in evolution?
Does thunderbird work for you on the same server?

Comment 4 Thilo Pfennig 2005-05-13 09:04:46 UTC
Yes, certainly, evolution also works, but not in "TLS only" mode. but Thunderird
works in "TLS only".

One example entry of my Exim-Log:

2005-05-13 08:57:17 1DWVyu-0000RK-Ra <= tp@alternativ.net
H=p548d81e5.dip0.t-ipconnect.de (stevie) [84.141.129.229] P=esmtpsa
X=TLS-1.0:RSA_ARCFOUR_MD5:16 A=login:username S=1982
id=1115974651.3405.6.camel@stevie

Comment 6 Matthew Barnes 2006-07-31 14:55:27 UTC
Is this bug still present in the latest Fedora Core 5 or Rawhide releases?

evolution-2.6.2-1.fc5.5  (FC5)
evolution-2.7.4-3  (Rawhide)

Comment 7 Thilo Pfennig 2006-07-31 15:24:36 UTC
no. you can close this bug.

Comment 8 Matthew Barnes 2006-07-31 15:41:11 UTC
Thanks.  Setting the resolution for this bug to RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.