Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157398 - [task] input strings gets committed in the wrong order in Evolution Task
Summary: [task] input strings gets committed in the wrong order in Evolution Task
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgal2
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker 157399
TreeView+ depends on / blocked
 
Reported: 2005-05-11 07:29 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
3 users (show)

Fixed In Version: 2-2.4.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-04 23:26:11 UTC


Attachments (Terms of Use)
proposed patch for gal (deleted)
2005-05-20 12:35 UTC, Akira TAGOH
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 303876 None None None Never

Description Lawrence Lim 2005-05-11 07:29:41 UTC
Description of problem:
In CJK locale, input characters gets replicated when they are not
comitted.

Version-Release number of selected component (if applicable):
evolution-webcal-2.2.0-1
evolution-2.2.2-5
evolution-data-server-1.2.2-2
evolution-devel-2.2.2-5
evolution-data-server-devel-1.2.2-2
evolution-connector-2.2.2-3
evolution-debuginfo-2.2.2-5

How reproducible:
Always

Steps to Reproduce:
1.Select any CJK locale at gdm and log in (in this example, we use Japan)
2.Start Evolution -> Select Task
3.Ctrl+SPACE to activate the Language Engine
4.Go to new task entry in the widget
5.Type "sushi" enter
6.Type "genki" enter
  
Actual results:
"genki" gets committed before the "sushi"

Expected results:
"genki" should be commiteed after "sushi"

Additional info:

Comment 1 Akira TAGOH 2005-05-20 12:35:22 UTC
Created attachment 114622 [details]
proposed patch for gal

I've tracked this down. though GDK_Return is filtered by
gtk_im_context_filter_keypress at ect_event in e-cell-text.c. but this function
is called with even GDK_KEY_RELEASE and gtk_im_context_filter_keypress is also
called again. e_table_leave_edit_ is called because it's not filtered. then
cursor position is reset.

Comment 2 Leon Ho 2005-05-23 05:02:59 UTC
There aren't any ways to input in Task properly with IM with this bug exists.
Moving it to FC4Blocker.

Comment 3 Dave Malcolm 2005-05-25 18:37:03 UTC
A possible workaround is to click on File->New->Task, so I believe that users
can create tasks despite the bug (the bug prevents the most visible way of
creating new tasks though).



Comment 4 Dave Malcolm 2005-05-25 19:34:09 UTC
Built with patch as libgal2-2.4.2-4 into dist-fc4-HEAD


Comment 6 Lawrence Lim 2005-06-28 01:48:43 UTC
I have noticed the update with the patch in the changelog but I wont be able to
test this bug properly until bug 154360 has been resolved.


Cheers.

Comment 7 Lawrence Lim 2005-06-28 04:28:25 UTC
Tested with libgal2-2.4.2-5 and evolution-2.2.2-8, confirmed bug has been fixed
in Evolution Task.

Thanks.

Comment 8 Lawrence Lim 2005-07-06 06:53:40 UTC
Tested with evolution-2.2.3-1.fc4 and libgal2-2.4.3-1.fc4 from
dist-fc4-updates-candidate, confirm the bug has been fixed.


Thanks.




Note You need to log in before you can comment on or make changes to this bug.