Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157397 - Preedit hidden after choosing the candidate
Summary: Preedit hidden after choosing the candidate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libgal2
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On: 154362
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-05-11 06:58 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-556
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 14:45:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:556 qe-ready SHIPPED_LIVE evolution and libgal2 bug fix and enhancement update 2005-10-05 04:00:00 UTC
GNOME Bugzilla 303874 None None None Never

Description Lawrence Lim 2005-05-11 06:58:15 UTC
+++ This bug was initially created as a clone of Bug #154362 +++

Description of problem:
Preedit is hidden after choosing the candidate in cannaLE candidate window

Version-Release number of selected component (if applicable):
evolution-2.2.1.1-2
evolution-data-server-1.2.1-1
iiimf-le-canna-12.1.1-11.svn2435

How reproducible:
everytime

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 evolution
2. Go to task list
3. Go to new task entry in the widget
4. Type "sushi", space, space 
5. In candidate window, press enter to select the candidate
  
Actual results:
preedit is hidden

Expected results:
preedit should be shown

Additional info:
continue to type again will re-show the preedit string.

Comment 1 Lawrence Lim 2005-05-11 06:58:53 UTC
There is a second part to this bug.

Actual results:
preedit is hidden and the selected candidates are not committed

Expected results:
preedit buffer should be destroyed and selected candidates gets committed

Additional info:
continue to type again will re-show the preedit string.


Tested with the following packages in EL4.

evolution-debuginfo-2.0.2-16
evolution-webcal-1.0.10-1
evolution-devel-2.0.2-16
evolution-connector-2.0.2-5
evolution-data-server-devel-1.0.2-7
evolution-2.0.2-16
evolution-data-server-1.0.2-7

Comment 2 Leon Ho 2005-06-03 04:26:58 UTC
This is important for evolution international inputs in RHEL4

Comment 8 Dave Malcolm 2005-07-26 19:37:55 UTC
Changing component from evolution-data-server to libgal2; fix affects both
libgal2 and evolution.

May be a duplicate of bug 154360


Comment 9 Dave Malcolm 2005-08-03 19:32:26 UTC
Built libgal2 part as libgal2-2.2.3-7
Built evolution part as evolution-2.0.2-19


Comment 10 Red Hat Bugzilla 2005-10-05 14:45:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-556.html



Note You need to log in before you can comment on or make changes to this bug.