Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157393 - CJK and Indic layout issue when printing from evolution cal
Summary: CJK and Indic layout issue when printing from evolution cal
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
: 171182 (view as bug list)
Depends On: 140309
Blocks: FC6Target FC4Update FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2005-05-11 06:05 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-25 21:52:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 303866 None None None Never

Description Lawrence Lim 2005-05-11 06:05:26 UTC
+++ This bug was initially created as a clone of Bug #140309 +++

Description of problem:
Printing the entries from the Evolution Calendars for CJK languages
has a common behaviour.

For zh_TW, ja_JP and ko_KO,
The numeric hours and the native characters which define the AM/PM are
overlapping.

Version-Release number of selected component (if applicable):
evolution-data-server-devel-1.0.2-4
evolution-devel-2.0.2-3
evolution-data-server-1.0.2-4
evolution-2.0.2-3
evolution-webcal-1.0.10-1
evolution-connector-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1.start evolution in any of the CJK locale, eg, LANG=zh_TW.UTF-8 evolution
2.click on the Calendar
3.print the Calendar

Actual results:
Please see the attached .ps file for each locale

Expected results:
Consistent with what is displayed on the screen

Additional info:

Comment 1 Lawrence Lim 2005-05-11 06:06:42 UTC
Tested with the following packages, the bug still exist.

evolution-webcal-2.2.0-1
evolution-2.2.2-5
evolution-data-server-1.2.2-2
evolution-devel-2.2.2-5
evolution-data-server-devel-1.2.2-2
evolution-connector-2.2.2-3
evolution-debuginfo-2.2.2-5

Comment 3 Satyabrata Maitra 2006-06-20 11:22:13 UTC
This bug is not fixed yet. It still exists. Tested on the package versions :

evolution-2.7.3-2
evolution-data-server-1.7.3-2
evolution-sharp-0.11.1-1
evolution-webcal-2.7.1-4

Tested on O.S. : Fedora Core Release 5.89 (Rawhide) i386.


Comment 4 Satyabrata Maitra 2006-06-20 11:37:11 UTC
Sorry for the comment no. 3. Wrong comment. Please ignore it.

This bug has been fixed and reported on bug id 140309. Test Result : PASS

Packages versions :

evolution-2.7.3-2
evolution-data-server-1.7.3-2
evolution-sharp-0.11.1-1
evolution-webcal-2.7.1-4

Tested on O.S. : Fedora Core Release 5.89 (Rawhide) i386.

Comment 5 Matthias Clasen 2006-07-06 21:57:48 UTC
Add to FC6Destop tracker

Comment 6 Leon Ho 2006-07-11 07:52:42 UTC
*** Bug 171182 has been marked as a duplicate of this bug. ***

Comment 7 Matthew Barnes 2006-07-11 18:04:37 UTC
(In reply to comment #4)
> This bug has been fixed and reported on bug id 140309. Test Result : PASS

Can this bug be closed now?


Note You need to log in before you can comment on or make changes to this bug.