Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157392 - Ethernet does not receive any packets, but send
Summary: Ethernet does not receive any packets, but send
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 05:53 UTC by Shida Satoshi
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 14:37:02 UTC


Attachments (Terms of Use)

Description Shida Satoshi 2005-05-11 05:53:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
On Intel SCB2 motherboard, all ethernet interfaces don't receive any packets.
But some ARP packets are sent. Also, if static ARP entry is set (arp -s command), some IP packets are sent with ping command.

This problem occured FC3, FC4t1, FC4t2, FC4t3, Enterprise Linux 4, with kernel 2.6.x.

Ethernet devices are onboard Intel e100 device, Tigon tg3 device (GbE-PCI), Intel e1000 device (GbE-PCI, 82544EI, copper, rev 02)

- Snet arp packets are observed on neighber machine with tcpdump,
  and replied arp packets are also observed, but FC4t3 box does not 
  show the IP/MAC addresses in FC4t3 arp table entry.
- I upgraded Intel e1000 driver to "6.0.54", but not resolved.
- vmstat shows 115/sec interrupts contantly
- SCB2 BIOS updated (BUILD 77), also BMC, FRUSDR firmware updated
- removed attached PCI Ethernet card, but not resolved
- ifconfig command shows the "Number of Rx packets" counted up (No error counts)

Version-Release number of selected component (if applicable):
kernel-2.6.11

How reproducible:
Always

Steps to Reproduce:
1. boot
2. ping to neighbor machine

Actual Results:  All ping failed

Expected Results:  All ping are replied.
ARP entries are added into kernel ARP entry table.

Additional info:

Comment 1 Shida Satoshi 2005-05-11 06:21:55 UTC
This Intel SCB2 box is running with Fedora Core 1 with no problem.

(Linux 2.4.22-1.2197.nptl #1 Thu Jul 1 15:14:28 EDT 2004 i686 i686 i386 GNU/Linux)

This problem may relate to "NETDEV WATCHDOG: eth0: transmit timed out" error
(#156945/RHEL, #139514/fc3/kernel-2.6.9-1.667).

Comment 2 John W. Linville 2005-05-11 13:44:00 UTC
Please attach the output of running "sysreport". 
 
It seems very strange that none of the interfaces would work.  Are you sure 
that your network configuration is correct? 

Comment 3 John W. Linville 2005-06-27 14:37:02 UTC
Closed due to lack of response...please reopen if/when requested information 
becomes available... 


Note You need to log in before you can comment on or make changes to this bug.