Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157391 - input preedit string gets replicated in Evolution Cal (FC4)
Summary: input preedit string gets replicated in Evolution Cal (FC4)
Keywords:
Status: CLOSED DUPLICATE of bug 166231
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On: 131227
Blocks: FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-05-11 05:53 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-31 14:57:29 UTC


Attachments (Terms of Use)
Patch to fix preedit buffer replication (deleted)
2006-05-22 12:14 UTC, Mayank Jain
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 264485 None None None Never

Description Lawrence Lim 2005-05-11 05:53:26 UTC
+++ This bug was initially created as a clone of Bug #131227 +++

Description of problem:
In CJK locale, input characters gets replicated when they are not
comitted.

Version-Release number of selected component (if applicable):
- evolution-data-server-0.0.97-2
- evolution-1.5.92.2-2
- im-sdl-12.0.1-1

How reproducible:
Always

Steps to Reproduce:
1.Select any CJK locale at gdm and log in (in this example, we use Japan)
2.Start Evolution -> Select Cal
3.Ctrl+SPACE to activate the Language Engine
4.Single click any of the time widget and enter 'aka' 
5.Repeat Step 4, you should see the charcters replicating 
  
Actual results:
Please refer to screen shot

Expected results:
Characers does not get replicated.

Additional info:
Tested in GNOME environment

Comment 1 Lawrence Lim 2005-05-11 05:55:35 UTC
Tested with the following packages in dist-FC4, the bug still exist.

evolution-webcal-2.2.0-1
evolution-2.2.2-5
evolution-data-server-1.2.2-2
evolution-devel-2.2.2-5
evolution-data-server-devel-1.2.2-2
evolution-connector-2.2.2-3
evolution-debuginfo-2.2.2-5


Comment 3 A S Alam 2006-05-22 11:01:22 UTC
working fine for ko_KR.UTF-8, but not for
ja_JP.UTF-8
 zh_CN.UTF-8

changed FC4->Devel

Test ON
------------------
evolution-sharp-0.11.1-1
evolution-data-server-1.7.1-2
evolution-webcal-2.4.1-3.2
evolution-2.7.1-1
evolution-data-server-devel-1.7.1-2
-------------------

Comment 4 Mayank Jain 2006-05-22 12:12:59 UTC
Hi Aman,

This patch seemingly fixes the problem.
Kindly have a look.

Thanks,
Mayank

Comment 5 Mayank Jain 2006-05-22 12:14:07 UTC
Created attachment 129792 [details]
Patch to fix preedit buffer replication

Comment 6 Mayank Jain 2006-06-21 06:45:55 UTC
No need for applying the patch, fixed in upstream code... adding the external
bugzilla ref - http://bugzilla.gnome.org/show_bug.cgi?id=264485

Comment 8 A S Alam 2006-06-26 14:03:24 UTC
Not working for ja_JP locale with following test envirnment:
---------------------
evolution-sharp-0.11.1-5
evolution-2.7.3-3
evolution-data-server-1.7.3-2
evolution-data-server-devel-1.7.3-2
evolution-webcal-2.7.1-4
---------------------

Comment 9 Mayank Jain 2006-07-06 08:59:10 UTC
Hi Matt,

The Patch in http://bugzilla.gnome.org/attachment.cgi?id=65213&action=view seems
to be missing from the latest builds. Can you please apply it to the latest code
base?

If you need any more info, please let me know.

Thanks,
Mayank

Comment 10 Matthew Barnes 2006-07-06 16:59:15 UTC
Done - evolution-2.7.3-8

Only two of the three hunks in the patch applied.  The third (plugs a memory
leak) is already fixed upstream.

Changing component from evolution-data-server to evolution.

Comment 11 A S Alam 2006-07-10 09:58:37 UTC
sorry, still string is replicated, test on following package

evolution-2.7.3-9

Comment 13 Matthew Barnes 2006-07-18 11:40:13 UTC
Mayank,

To apply the patch manually, do so from Evolution's root directory:

    $ cd evolution-2.7.4
    $ patch -p1 < evolution-2.7.3-replicated-cjk-input.patch

The -p1 option tells patch to ignore the first component of the path when
applying the patch-file (in this case, "evolution-2.7.3/").  This is what the
spec file does when automatically applying the patches.

Keeping the version in the patch-file helps us keep track of what version of
Evolution the patch-file was _really_ generated from, since the patch-file's
name in CVS does not always accurately reflect this.

Let me know if I misunderstood your question, or if you're still having trouble.

Matt

Comment 14 Mayank Jain 2006-07-18 13:06:40 UTC
Oh, yeah...

Just had a look at this line
%patch904 -p1 -b .replicated-cjk-input

I did knew what you just wrote, but probably missed this line. Thanks!

Btw, just found that you can saftely delete
evolution-2.7.2-preedit-gnome.bz-264485.patch & clean it up from the spec file
as it is already not being applied, its my old unaccepted patch.

Thanks :)

Comment 15 Matthew Barnes 2006-08-07 13:35:36 UTC
Mayank, any progress on this upstream?

Comment 16 A S Alam 2006-08-31 14:57:29 UTC

*** This bug has been marked as a duplicate of 166231 ***


Note You need to log in before you can comment on or make changes to this bug.