Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157388 - Moving email to the trash by the right mouse button fails sometimes
Summary: Moving email to the trash by the right mouse button fails sometimes
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 05:10 UTC by Joachim Backes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-12 02:31:23 UTC


Attachments (Terms of Use)

Description Joachim Backes 2005-05-11 05:10:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Moving an email to some folder by clicking on it in the main window by the right mouse button and then saying: "move to folder" fails sometimes because the desired folder can't be selected in the offered target list.

But it can be moved by selecting the move button in the evolution main upper button bar.

Version-Release number of selected component (if applicable):
evolution-2.0.4-4

How reproducible:
Sometimes

Steps to Reproduce:
1.Select an email in the main window by the right mouse button
2.Say Move to ...
3.
  

Actual Results:  Target may not be selected

Expected Results:  Target may be selected

Additional info:

--

Comment 1 Dave Malcolm 2005-05-12 02:31:23 UTC
Thanks for the report.  I'm seeing this with the very latest packages
(evolution-2.2.2).  You can only select "actual" folders; the Trash folder is a
virtual folder of emails marked for deletion (similar for the Junk folder).  

That dialog could potentially be improved.  At the moment, the Fedora developers
don't have time to work on this particular issue. The best way to make sure your
problem will get looked on is to report it to the authors of the program. Most
upstream authors use a bug tracking system like bugzilla, and more people who
know the code will be looking at the bug report there.

The upstream bug tracking system to use is:
http://bugzilla.gnome.org/

Please make sure the bug isn't already in the upstream bug tracker before
filing it.


Note You need to log in before you can comment on or make changes to this bug.