Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157383 - There is no extension name of a locale file.
Summary: There is no extension name of a locale file.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tcsh
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Bill Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 02:59 UTC by Tadashi Jokagi
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 08:18:52 UTC


Attachments (Terms of Use)

Description Tadashi Jokagi 2005-05-11 02:59:57 UTC
There is no extension name of a locale file.

Version-Release number of selected component (if applicable):
# rpm -q tcsh
tcsh-6.14-1


How reproducible:

Steps to Reproduce:
1.run "rpm -ql tcsh | grep locale"
2.
3.
  
Actual results:
rpm -ql tcsh|grep locale
/usr/share/locale/de/LC_MESSAGES/tcsh
/usr/share/locale/el/LC_MESSAGES/tcsh
/usr/share/locale/en/LC_MESSAGES/tcsh
/usr/share/locale/es/LC_MESSAGES/tcsh
/usr/share/locale/et/LC_MESSAGES/tcsh
/usr/share/locale/fi/LC_MESSAGES/tcsh
/usr/share/locale/fr/LC_MESSAGES/tcsh
/usr/share/locale/it/LC_MESSAGES/tcsh
/usr/share/locale/ja/LC_MESSAGES/tcsh
/usr/share/locale/pl/LC_MESSAGES/tcsh
/usr/share/locale/ru/LC_MESSAGES/tcsh
/usr/share/locale/uk/LC_MESSAGES/tcsh

Expected results:
rpm -ql tcsh|grep locale
/usr/share/locale/de/LC_MESSAGES/tcsh.mo
/usr/share/locale/el/LC_MESSAGES/tcsh.mo
/usr/share/locale/en/LC_MESSAGES/tcsh.mo
/usr/share/locale/es/LC_MESSAGES/tcsh.mo
/usr/share/locale/et/LC_MESSAGES/tcsh.mo
/usr/share/locale/fi/LC_MESSAGES/tcsh.mo
/usr/share/locale/fr/LC_MESSAGES/tcsh.mo
/usr/share/locale/it/LC_MESSAGES/tcsh.mo
/usr/share/locale/ja/LC_MESSAGES/tcsh.mo
/usr/share/locale/pl/LC_MESSAGES/tcsh.mo
/usr/share/locale/ru/LC_MESSAGES/tcsh.mo
/usr/share/locale/uk/LC_MESSAGES/tcsh.mo

Additional info:

Comment 1 Miloslav Trmač 2005-05-11 08:18:52 UTC
The files are catgets catalogs, not gettext catalogs. The ".mo" extension is
used for gettext catalogs.

tcsh is opening a catalog named "tcsh" by default. Because the default NLSPATH
is /usr/share/locale/%L/%N:/usr/share/locale/%L/LC_MESSAGES/%N , the catalogs
have to 
be installed without the .mo extension, otherwise they would not be used
automatically.


Note You need to log in before you can comment on or make changes to this bug.