Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157381 - Segmentation fault on DEL
Summary: Segmentation fault on DEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texinfo
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 02:42 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.8-2.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-15 12:50:49 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2005-05-11 02:42:41 UTC
Description of problem:

Type 'info date' and hit DEL key twice. On the second hit consistently:
"Moving to `Prev's last menu item.Segmentation fault"

This happens both on x86_64 and i386.  Neither old info-4.1-1 nor
info-4.8-4 from rawhide seems to be afflicted by this disease.

Interestingly enough using 'p' key instead of DEL does not have this
effect.  Type 'info date', 'u', and now after a longer series of 'p'
one gets to "No `Prev' pointer for this node" message and no crash.

Version-Release number of selected component (if applicable):
info-4.7-5

How reproducible:
always

Comment 1 Tim Waugh 2005-05-11 09:46:02 UTC
Same as bug #147000.  Maybe this needs a Fedora update.

Comment 2 Tim Waugh 2005-05-12 11:10:49 UTC
https://www.redhat.com/archives/fedora-test-list/2005-May/msg00462.html

Does this fix the problem for you?

Comment 3 Michal Jaegermann 2005-05-12 16:00:28 UTC
> Does this fix the problem for you?

Yes, indeed, it does.  I tried other key sequences, some of them rather long,
and so far I did not find anything which would cause segfault.  Not surprising 
as this is not 4.7 anymore.  Not that I am attached to a specific version. :-)

Comment 4 Miloslav Trmač 2006-01-15 12:50:49 UTC
Thanks for confirmation, texinfo-4.8-2.2 was released for FC3 in October 2005.


Note You need to log in before you can comment on or make changes to this bug.