Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 157378 - nss_ldap segfaults when "ssl start_tls" is in /etc/ldap.conf
Summary: nss_ldap segfaults when "ssl start_tls" is in /etc/ldap.conf
Keywords:
Status: CLOSED DUPLICATE of bug 156582
Alias: None
Product: Fedora
Classification: Fedora
Component: nss_ldap
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-11 01:29 UTC by Mark Goodman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 00:57:26 UTC


Attachments (Terms of Use)

Description Mark Goodman 2005-05-11 01:29:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
I saw this behavior in fc4test1 and fc4test2 as well but not in fc3.

Here's the gdb backtrace from running su with an LDAP user name.

#0  0x00882f1e in ber_sockbuf_ctrl () from /lib/libnss_ldap.so.2
#1  0x00877c1a in ldap_pvt_tls_inplace () from /lib/libnss_ldap.so.2
#2  0x00879917 in ldap_start_tls_s () from /lib/libnss_ldap.so.2
#3  0x00853e3d in do_open () at ldap-nss.c:1273
#4  0x00854025 in do_init2 () at ldap-nss.c:959
#5  0x00854e49 in _nss_ldap_search_s (args=0xbfb88284,
    filterprot=0xa94200 "(&(objectclass=posixAccount)(uid=%s))",
    sel=LM_PASSWD, user_attrs=0x0, sizelimit=1, res=0xbfb88238)
    at ldap-nss.c:2726
#6  0x00855e19 in _nss_ldap_getbyname (args=0xbfb88284, result=0x454074,
    buffer=0x8c76858 "gdm", buflen=1024, errnop=0xb7f7c6a0,
    filterprot=0x3 <Address 0x3 out of bounds>, sel=LM_HOSTS,
    parser=0x856503 <_nss_ldap_parse_pw>) at ldap-nss.c:3099
#7  0x008563cd in _nss_ldap_getpwnam_r (name=0x3 <Address 0x3 out of bounds>,
    result=0x3, buffer=0x3 <Address 0x3 out of bounds>, buflen=3, errnop=0x3)
    at ldap-pwd.c:210
#8  0x003b7b9e in getpwnam_r@@GLIBC_2.1.2 () from /lib/libc.so.6
#9  0x003b7664 in getpwnam () from /lib/libc.so.6
#10 0x00231ec6 in main (argc=2, argv=0xbfb88554) at su.c:727


Version-Release number of selected component (if applicable):
nss_ldap-234-2

How reproducible:
Always

Steps to Reproduce:
1. Install nss_ldap debuginfo RPM.
2. Boot to single user mode.
3. /sbin/service network start
4. gdb su
5. set args <LDAP user name>
6. run

Additional info:

I can work around it by using "ssl on" instead of "ssl start_tls" in /etc/ldap.conf.

When I boot to a multiuser mode, I can't login even as root with "ssl start_tls" in /etc/ldap.conf.

Comment 1 Jeremy Katz 2005-05-19 00:57:26 UTC

*** This bug has been marked as a duplicate of 156582 ***


Note You need to log in before you can comment on or make changes to this bug.